Calendar and newsfeed loading...



  • Hi everybody,

    I’m trying to set up my MM in my Rpi 2+ but I’m not able to have calendar and newsfeed working. They’re stilll loading.
    Clock, weather and forecast weather worked fine.

    For the Calendar, I’ve tried my private Google Calendar and others public calendars but no one works.
    For the newsfeed, I’ve tried many rss feeds and it’s still the same thing.

    Node.js is v6.5

    JSHint says no trouble with my config,js

    Pull is already up-to-date

    Thanks for the help



  • @elfary any errors in the terminal or electron console (CMD+SHIFT+I or starting mirror with npm start dev)?



  • Starting with npm start dev shows me a lot of errors!!!

    magicmirror@2.0.0 start /home/pi/MagicMirror
    electron js/electron.js “dev”

    npm ERR! Linux 4.4.13-v7+
    npm ERR! argv "/usr/bin/nodejs" "/usr/bin/npm" "start" "dev"
    npm ERR! node v6.5.0
    npm ERR! npm  v3.10.3
    npm ERR! code ELIFECYCLE
    npm ERR! magicmirror@2.0.0 start: `electron js/electron.js "dev"`
    npm ERR! Exit status 1
    npm ERR!
    npm ERR! Failed at the magicmirror@2.0.0 start script 'electron js/electron.js "dev"'.
    npm ERR! Make sure you have the latest version of node.js and npm installed.
    npm ERR! If you do, this is most likely a problem with the magicmirror package,
    npm ERR! not with npm itself.
    npm ERR! Tell the author that this fails on your system:
    npm ERR!     electron js/electron.js "dev"
    npm ERR! You can get information on how to open an issue for this project with:
    npm ERR!     npm bugs magicmirror
    npm ERR! Or if that isn't available, you can get their info via:
    npm ERR!     npm owner ls magicmirror
    npm ERR! There is likely additional logging output above.
    
    npm ERR! Please include the following file with any support request:
    npm ERR!     /home/pi/MagicMirror/npm-debug.log
    


  • Don’t worry. I’ve reinstalled everything from scratch an it works


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.