MMM-Syslog not working anymore?



  • Hi everybody,

    I am not sure why, but my MMM-Syslog is not working anymore.
    As far as I remember the last two thinks I have done, was installing Alexa on the same Raspberry and updating the Magic Mirror.
    In order to find the error I just set up a new MagicMirror without Alexa. Same here. So I think it is because of the MagicMirror update?

    My browser says that there is no connection possible.
    I was working fine before.
    Even from my smart home I could send message until now.

    Do you have an idea?
    Could you please try your MMM-Syslog module?

    Thanks a lot!

    Mr.Coffee


  • Module Developer

    @MrCoffee

    There was changes made to ipWhitelist for the last couple of updates. Have you checked that you can access your mirror from another computers browser?



  • This post is deleted!


  • @broberg

    Hi broberg,

    thank you for your reply.
    Yes. I checked it from another computers browser. That is were it says “no connection possible”.

    However, I just tried to install an older version of MagicMirror on another SD-Card.
    The 2.1.2 from Juli has the same problem.
    The 2.1.1 from April looks much better. The browser finds the mirror sending this errormessage:
    “This device is not allowed to access your mirror.
    Please check your config.js or config.js.sample to change this.”

    Theoretically I know what to do with the config. But in generall I was not able to install the old version properly as I have to do it manualy. For example the config file was completely missing and I added it manualy.
    Help is welcome:-)

    But despite that. Now I know for sure that the problem exists since update 2.1.2.
    Do you have an idea why or how to fix it?

    Until it is fixed I would like to reinstall the 2.1.2 manually, but don´t know how. I used the automatic installer a few month ago.

    Thanks
    Mr.Coffee



  • @broberg

    “Have you checked that you can access your mirror from another computers browser?”

    Sorry. I have misunderstood that.
    I checked it with the MMM-syslog command. How can I check it another way?
    I tried the ip of the raspberry and could open the apache webserver.



  • I just made a port-scan.
    The raspberry with the older version has 8080/tcp http-proxy open. The other raspberry has not.
    I guess that MagicMirror opens or closes the port? I did nothing like that.


  • Module Developer

    @MrCoffee

    Access your pi from your main computers browser via http://raspberryip:8080

    If you get “device not allowed” you need to alter your ipwhitelist in the config.
    There are a couple of threads on how to set it up.
    But to just rule out any other issues, try this in your config first and see if you get access to your MM after that :

    var config = {
    address: "",
    port: 8080,
    ipWhitelist: [],
    
    //etc etc etc
    

    Why are you running an apache server on your MM?



  • @broberg

    Now it works like a charm!
    Thank you very much.

    I compared my config.js with your code. The [address: “”,] was missing.
    What does it do?

    I deleted my code and inserted yours in total and that was it.
    The strange thing is that I did not changed anything in the config. So maybe it might be because of the update.
    Now even my portscanner detects the port 8080.

    Thanks again.
    I´m very happy.

    Greetings
    Mr.Coffee



  • @broberg
    The apache server is for some smart home function.
    Has nothing to do with the MagicMirror … yet;-)