Magic mirror booting for first time



  • Hello everyone,

    Yesterday I began installing all that was necessary for my magic mirror with this tutorial. After some bugs, I finally managed to make this start but then… this happened (please ignore the wrong resolution, I still have to find a way to stabilize that since it sometimes changes when booting)

    So my question is: can it possibly come from the way I installed this? Or is it really my config.js file?

    Since you probably can’t tell without my config file, here it is:

    /* Magic Mirror Config Sample
     *
     * By Michael Teeuw http://michaelteeuw.nl
     * MIT Licensed.
     */
    
    var config = {
    	port: 8080,
    
    	language: 'fr',
    	timeFormat: 24,
    	units: 'metric',
    
    	modules: [
    		{
    			module: 'alert',
    		},
    		{
    			module: 'clock',
    			position: 'top_left'
    		},
    		{
    			module: 'calendar',
    			header: 'Calendrier',
    			position: 'top_left',
    			config: {
    				calendars: [
    					{
    						symbol: 'calendar-check-o ',
    						url: 'webcal://www.calendarlabs.com/templates/ical/US-Holidays.ics'
    					}
    				]
    			}
    		},
    		{
    			module: 'compliments',
    			position: 'lower_third'
    				config: {
    					compliments:{
    						morning:[
    							'blablabla!',
    							'blablabla!',
    							'blabalbal!'
    						]
    						afternoon:[
    							'blablabal',
    							'blabalbal!!'
    						]
    						evening:[
    							'blabalbal!!',
    							'blablabla?'
    						]
    					}
    				}
    		},
    		{
    			module: 'currentweather',
    			position: 'top_right',
    			config: {
    				location: 'Paris',
    				locationID: '2988507',  //ID from http://www.openweathermap.org
    				appid: '31a8ba8d6d5dc4953cc52ba06a675ecf'
    			}
    		},
    		{
    			module: 'weatherforecast',
    			position: 'top_right',
    			header: 'Weather Forecast',
    			config: {
    	            location: 'Paris',
    				locationID: '2988507',  //ID from http://www.openweathermap.org
    	            appid: '31a8ba8d6d5dc4953cc52ba06a675ecf'
    			}
    		},
    		{
    			module: 'newsfeed',
    			position: 'bottom_bar',
    			config: {
    				feeds: [
    					{
    						title: "Libération",
    						url: "rssliberationfr/rss/latest/",					},
    				],
    				showSourceTitle: true,
    				showPublishDate: true
    			}
    		},
    	]
    
    };
    
    /*************** DO NOT EDIT THE LINE BELOW ***************/
    if (typeof module !== 'undefined') {module.exports = config;}
    

    Note from admin: Please use Markdown on code snippets for easier reading!



  • position: 'lower_third'
    comma seems missing at the end of the line

    When you get an error like this, remove everything and add module config one by one, it helps to find the issue

    ps: and yes, this comma mistake happens to everyone :)


  • MagicMirror Creator

    Please note that the guide you followed is ⚠︎EXTREMELY OUTDATED⚠︎. Please check this guide:
    https://forum.magicmirror.builders/topic/236/complete-setup-tutorial



  • So, should I re-install everything with the new guide?

    If the missing coma doesn’t make it work I will anyway, thank you both!!


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.