Maximum File Size of ics FIle?



  • Hey everyone,

    i stumbled over the MagicMirror Project almost a year ago and was already then hooked!
    I am now currently building my own, but i got a problem with the Calender plugin.

    My main Google Calender won’t load. All i get is "Loading…"
    I tried to open the FIle via Chrome and it imediatly downloaded it (https://calendar.google.com/calendar/ical/myname%40gmail.com/private-key/basic.ics).

    The file size is 1,35MB - is this a problem for the mirror? Because any other File (like a Holiday ics from the web with 27KB or even my quick created test gmail account with only one appointment) will load and display the events on the mirror…

    Is there any way to fix this?

    I’m running the newest version of the MagicMirror on a Raspi 3
    PRETTY_NAME="Raspbian GNU/Linux 9 (stretch)"
    NAME="Raspbian GNU/Linux"
    VERSION_ID="9"
    VERSION=“9 (stretch)”

    Any help is apreciated - even if it is a workaround…
    Thanks!



  • @Stef Just checked, and my largest calendar is 425Kb, so I can’t say what is “too big”.

    Is this from an online service like Google or Outlook? You may be able to use query parameters to specify start/end dates (edit: more detailed description and API links here) for your query to return fewer results. If not, apparently some CalDAV servers (like DAVDroid) also allow you to pass parameters for start/end dates for the calendar. You can then create a query to (e.g.) only return events for this month and next.

    Alternatively, you might instead look at this post. You may have to change the config for whatever service you’re using, but in vdirsyncer you can set start_date and end_date options which should slice your calendar into something reasonable that you can then serve locally from your Pi. It’s not as simple as pointing a module at a URL, but once set up with a cron job should be pretty reliable.



  • @ninjabreadman (nice name btw)
    Thanks for your headsup.
    Yes this is directly from Google.
    Unfortuantley, adding the start/end dates won’t work. It seems to me, that i have to make my calendar public, in order to use this… and i do not want this.

    I’ll try to find the time to check out your other Hint with vdirsyncer. Looks easy enough.

    I’ll keep you posted!

    Thanks and a nice weekend



  • Ok… I am stuck…

    The Google API creation wasn’t a problem, and installing the vdirsyncer worked well also.

    But now i am supposed to create a conifg file in ~/.vdirsyncer/config - but i get an error everytime, that this File or Folder can’t be found…

    If i run ls -l in usr/bin, i get the following output:
    lrwxrwxrwx 1 root root 30 Feb 3 21:32 vdirsyncer -> /home/pi/.local/bin/vdirsyncer

    So… it is an folder… but why can’t i access it??
    Am i missing something?

    thanks!



  • @Stef You first need to create the config file (i.e. via touch):

    touch ~/.vdirsyncer/config
    nano ~/.vdirsyncer/config
    

    Yes, .vdirsyncer exists, but config doesn’t (yet).



  • Yes i know :(
    But everytime i enter

    touch ~/.vdirsyncer/config

    i get, that it can’t find the directory…
    (" touch: ‘/home/pi/.vdirsyncer/config’ kann nicht ber▒hrt werden: Datei oder Verzeichnis nicht gefunden")



  • @Stef Ah, i think you have the symlink to vdirsyncer but not the hidden folder, .vdirsyncer (in your home folder) for config options.

    Type mkdir ~/.vdirsyncer then try again to create the config file.



  • YES! Thanks!
    I didn’t realised that…



  • Uhoh… i almost forgot:
    It all works like a charme now!

    Thank you @ninjabreadman!

    …Maybe i will write a litlle howto… but after all it was pretty straight forward.

    This Thread can be closed now.



  • @Stef That’s awesome, congrats. Thanks for letting us know!

    If anything, comment on @Beh’s post with any edits or additions you suggest to help others.

    Cheers!


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.