MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

RPi Zero Troubleshooting



  • I’ve followed the guide at https://forum.magicmirror.builders/topic/1183/how-i-got-my-magic-mirror-working-on-a-raspberry-pi-0-zero to get MM installed on my RPi Zero W using Jessie Lite, but I’m having some issues now that the install is complete.

    Once Midori opens up (or if I connect to it using a browser on my PC), the screen is just black, and on the Pi I get the messages when the server starts:

    :::

    Starting MagicMirror: v2.2.2
    Loading Config …
    Loading module helpers …
    No helper found for module: alert.
    Initializing new module helper …
    Module helper loaded: updatenotification
    No helper found for module: clock.
    Initializing new module helper …
    Module helper loaded: calendar
    No helper found for module: compliments.
    No helper found for module: currentweather.
    No helper found for module: weatherforecast.
    Initializing new module helper …
    Module helper loaded: newsfeed.
    All module helpers loaded.
    Starting server on port 8080 …
    You’re using a full whitelist configuration to allow for all IPs
    Server started …
    Connecting socket for: update
    Connecting socket for: calendar
    Starting node helper for: calendar
    Connecting socket for: newsfeed
    Starting module: newsfeed
    Sockets connected & modules started …

    :::

    I’m not really sure where to go from here but any help would be appreciated.



  • Did some digging in the forums and found that

    npm install --unsafe-perm

    Looks to have fixed my issue!