Installing USB Soundcard using seperate USB Mic



  • Hi,

    I use a Pi 3 with jessie.
    My Monitor doesn´t have HDMI thats why I use the audio jack of the Pi to play sound to the monitor speakers.
    Additionaly I use a usb mic.
    This setting works fine, but the audio out is very silent. Thats why I want to add a usb soundcard (just for audio out).

    And here my problem starts. The Pi always plays sound over the audio jack. No matter what.

    I already spended hours searching the internet and trying different thinks.
    Here are some outputs:

    lsusb:

    Bus 001 Device 004: ID 0d8c:013c C-Media Electronics, Inc. CM108 Audio Controller
    Bus 001 Device 005: ID 0d8c:0014 C-Media Electronics, Inc.
    Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
    Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    

    It is Device 5.

    aplay -l:

    **** Liste der Hardware-Geräte (PLAYBACK) ****
    Karte 0: Device_1 [USB Audio Device], Gerät 0: USB Audio [USB Audio]
      Sub-Geräte: 1/1
      Sub-Gerät #0: subdevice #0
    Karte 2: ALSA [bcm2835 ALSA], Gerät 0: bcm2835 ALSA [bcm2835 ALSA]
      Sub-Geräte: 8/8
      Sub-Gerät #0: subdevice #0
      Sub-Gerät #1: subdevice #1
      Sub-Gerät #2: subdevice #2
      Sub-Gerät #3: subdevice #3
      Sub-Gerät #4: subdevice #4
      Sub-Gerät #5: subdevice #5
      Sub-Gerät #6: subdevice #6
      Sub-Gerät #7: subdevice #7
    Karte 2: ALSA [bcm2835 ALSA], Gerät 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
      Sub-Geräte: 1/1
      Sub-Gerät #0: subdevice #0
    

    arecord -l:

    **** Liste der Hardware-Geräte (CAPTURE) ****
    Karte 0: Device_1 [USB Audio Device], Gerät 0: USB Audio [USB Audio]
      Sub-Geräte: 1/1
      Sub-Gerät #0: subdevice #0
    Karte 1: Device [USB PnP Sound Device], Gerät 0: USB Audio [USB Audio]
      Sub-Geräte: 0/1
      Sub-Gerät #0: subdevice #0
    

    So, card 0 aka Device_1 is my usb soundcard and card 1 aka Device is my microphone.

    cat /proc/asound/modules:

    0 snd_usb_audio
    1 snd_usb_audio
    2 snd_bcm2835
    

    I didn´t touch the configuration but both usb´s are starting before the internal soundcard.

    I tried different /etc/asound.conf, for expample:

    #defaults.ctl.card 0
    #defaults.pcm.card 0
    pcm.!default {
        type asym
        playback.pcm "plughw:Device_1"
        capture.pcm  "plughw:Device"
    }
    

    or

    pcm.!default {
      type asym
       playback.pcm {
         type plug
         slave.pcm "hw:0,0"
       }
       capture.pcm {
         type plug
         slave.pcm "hw:1,0"
       }
    }
    

    I even edited the default devices in the /usr/share/alsa/alsa.conf.
    No luck at all.

    I am thankful for every help.



  • @mrcoffee
    give it a try

    pcm.!default {
      type asym
      capture.pcm "mic"
      playback.pcm "speaker"
    }
    pcm.mic {
      type plug
      slave {
        pcm "hw:0,0"
      }
    }
    pcm.speaker {
      type plug
      slave {
        pcm "hw:0,0"
      }
    }
    

    or

    pcm.!default {
      type asym
      capture.pcm "mic"
      playback.pcm "speaker"
    }
    pcm.mic {
      type plug
      slave {
        pcm "hw:0,0"
      }
    }
    pcm.speaker {
      type plug
      slave {
        pcm "hw:1,0"
      }
    }
    

    then restart with sudo /etc/init.d/alsa-utils restart
    under alsamixer can still adjust the volume level



  • @NoNameRo

    Thank you for your fast response.
    Unfortunately it is still not working. I tried both versions and restarted with the command you told me.
    I even rebootet just to be sure.
    What I didnt do is switching the cable from jack to the usb soundcard, because it is late and the mirror on the wall again. But I expect, that it would be mute if it works, right?

    I forgot to write above, that I can see all 3 devices in the alsamixer.



  • @mrcoffee
    I have seen solutions to this here: https://raspberrypi.stackexchange.com
    search there.

    Also, only use ONE sound card for AUX (ouput) and MIC (input). Otherwise you will get confused and so your Pie will be unhappy too. It is also highly recommended to disable the internal broadcom sound card when using a USB card. That you can do in the boot config IIRC.



  • @e3v3a
    Now it is getting weired.
    I disabled the internal broadcom by adding it to the blacklist:

    sudo tee /etc/modprobe.d/blacklist-snd_bcm2835.conf
    
    blacklist snd_bcm2835
    

    After reboot it is correctly not shown again:

    aplay -l

    **** Liste der Hardware-Geräte (PLAYBACK) ****
    Karte 0: Device_1 [USB Audio Device], Gerät 0: USB Audio [USB Audio]
      Sub-Geräte: 1/1
      Sub-Gerät #0: subdevice #0
    

    But if I start playing a media, the sound still comes from the audio jack.
    How can that be?



  • dtparam=audio=off



  • @e3v3a
    Thanks for the help.
    I didn´t tried it yet because meanwhile my mic has some problems too. The “beep” from Alexa ist still there but sounds already not round. After that the mic does not react at all.

    Guess I will reset the whole system. Unfortunately I did not have a backup.
    By the way: If anybody of you knows a raspberry backup programm which I can use under windows please let me know.

    I will inform you when I reseted my system.



  • @MrCoffee I don’t think resetting it is gonna be helpful, unless you know you have installed a bunch of other apt packages, and messed with system settings without writing down what you did.





  • @E3V3A
    Hi, I tried the steps from “cloning” to "sudo /home/pi/GassistPi/audio-drivers/USB-MIC-JACK/scripts/usb-mic-onboard-jack.sh " (I have got Alexa not google assistant;-))
    The alexa beep sounds normal again, but after that there is silence. And I can still force the beep only once per reboot.


 

243
Online

6.0k
Users

4.5k
Topics

37.2k
Posts