MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

Error starting MagicMirror after an update



  • I ran an update on my Magic Mirror last night and now it will not launch. 😕

    I get the following error:
    pi@raspi-calendar:~/MagicMirror $ npm start

    magicmirror@2.4.1 start /home/pi/MagicMirror
    sh run-start.sh

    run-start.sh: 4: run-start.sh: electron: not found
    npm ERR! file sh
    npm ERR! code ELIFECYCLE
    npm ERR! errno ENOENT
    npm ERR! syscall spawn
    npm ERR! magicmirror@2.4.1 start: sh run-start.sh
    npm ERR! spawn ENOENT
    npm ERR!
    npm ERR! Failed at the magicmirror@2.4.1 start script.
    npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

    npm ERR! A complete log of this run can be found in:
    npm ERR! /home/pi/.npm/_logs/2018-07-18T01_07_05_492Z-debug.log

    And in the debug.log:

    0 info it worked if it ends with ok
    1 verbose cli [ ‘/usr/bin/node’, ‘/usr/bin/npm’, ‘start’ ]
    2 info using npm@5.6.0
    3 info using node@v10.1.0
    4 verbose run-script [ ‘prestart’, ‘start’, ‘poststart’ ]
    5 info lifecycle magicmirror@2.4.1~prestart: magicmirror@2.4.1
    6 info lifecycle magicmirror@2.4.1~start: magicmirror@2.4.1
    7 verbose lifecycle magicmirror@2.4.1~start: unsafe-perm in lifecycle true
    8 verbose lifecycle magicmirror@2.4.1~start: PATH: /usr/lib/node_modules/npm/node_modules/npm-lifecycle/node-gyp-bin:/home/pi/MagicMirror/node_modules/.bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/local/games:/usr/games
    9 verbose lifecycle magicmirror@2.4.1~start: CWD: /home/pi/MagicMirror
    10 silly lifecycle magicmirror@2.4.1~start: Args: [ ‘-c’, ‘sh run-start.sh’ ]
    11 info lifecycle magicmirror@2.4.1~start: Failed to exec start script
    12 verbose stack Error: magicmirror@2.4.1 start: sh run-start.sh
    12 verbose stack spawn ENOENT
    12 verbose stack at ChildProcess. (/usr/lib/node_modules/npm/node_modules/npm-lifecycle/lib/spawn.js:48:18)
    12 verbose stack at ChildProcess.emit (events.js:182:13)
    12 verbose stack at maybeClose (internal/child_process.js:957:16)
    12 verbose stack at Process.ChildProcess._handle.onexit (internal/child_process.js:246:5)
    13 verbose pkgid magicmirror@2.4.1
    14 verbose cwd /home/pi/MagicMirror
    15 verbose Linux 4.9.70-v7+
    16 verbose argv “/usr/bin/node” “/usr/bin/npm” “start”
    17 verbose node v10.1.0
    18 verbose npm v5.6.0
    19 error file sh
    20 error code ELIFECYCLE
    21 error errno ENOENT
    22 error syscall spawn
    23 error magicmirror@2.4.1 start: sh run-start.sh
    23 error spawn ENOENT
    24 error Failed at the magicmirror@2.4.1 start script.
    24 error This is probably not a problem with npm. There is likely additional logging output above.
    25 verbose exit [ 1, true ]

    Please help!

    Thank you,
    Major


  • Project Sponsor

    @major - It looks like electron didn’t install properly.

    If you run npm install from inside the /home/pi/MagicMirror folder, it should automatically install electron. If that doesn’t work, you can install electron specifically by typing sudo npm install electron@2.0.0



  • I’m sorry, I didn’t report back.

    Running npm install did the trick!

    Thank you!


Log in to reply