MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

MM Crashed twice. Time to abandon MM?



  • Getting steadily more disillusioned with the whole MM project. 😞

    Twice recently it’s crashed, at 01:09, and 21:44
    When it boots back up again, the screen flashes blank a few times before it settles.

    Pi feels warm, temp shows 63.4C - despite making the changes to the Pi config.

    I tend mostly to view MM on a browser away from the host Pi.
    Would running MM in ‘server mode’ avoid the Electron browser temp problem?

    But if it keeps crashing like this, I think I might abandon the whole thing, and use the Pi for something else.



  • It’s currently running at 74.1C



  • Did you do the thing with the dtoverlay=vc4-fkms-v3d in your config.txtas it’s written in the Wiki? What’s the ambient temperature? Mine is running between 62°C and 65°C with peaks at 67°C at 27°C room temperature. It also crashes fairly often. I basically have to restart it every morning but for the moment I blame the buck converter which might have problems with the temperature and the load. I will see after I improved cooling.

    If you don’t display the MM on a screen connected to the Pi I suppose node serveronlywill do the job better. Just give it a try and report back.



  • @madscientist

    I tried

    dtoverlay=vc4-fkms-v3d
    

    That doesn’t work for me, MM boots to a few lines about blocks, then nothing else.
    (see https://forum.magicmirror.builders/topic/7554/applied-change-to-config-txt-mm-fails-to-boot/6)

    I used rpi config instead.

    Ambient room temp is about 23/24C

    “buck converter”?

    Will try serveronly when I get a moment.


  • Project Sponsor

    @richard238 - If you’re viewing the Magic Mirror interface away from the Pi itself, then yeah I think it’s worth not starting the Electron service and running node serveronly. A significant portion of the issues with the Magic Mirror framework have been connected to the… inability of Electron to display the interface efficiently.



  • How then do I convert my existing MM to serveronly?

    All the instructions seem to be for making a serveronly MM from the start.

    Thanks.



  • @richard238 Just enter your MM directory (e.g. cd Magicmirror) and run node serveronly. That should be all. Don’t forget to whitelist the IP of your remote computer, which will display MM.



  • Ok, I’ll try that, thank you.

    How do I get it back if I want to?
    And can I still VNC to the Pi desktop?



  • Not sure since I don’t use the node serveronlyin my setup but a simple ctrl+cmight do the trick. Or you use pm2. Make a short script with nano mm_so.shand paste the following (make sure your MagicMirror directory is correct)

    cd ~/MagicMirror
    node serveronly
    

    ctrl+xfollowed by a confirmation with ywill save it. Then type chmod a+x mm_so.sh.
    If you have pm2 installed you can then just run it by typing pm2 start mm_so.sh. You stop it again by just entering pm2 stop mm_so.

    Disclaimer: I haven’t tried any of the above and it might contain errors or be simply wrong. Just give it a try. It doesn’t break anything.


  • Project Sponsor

    @richard238 - To supplement @MadScientist excellent post, VNC works regardless of the Magic Mirror process state.

    The default installation of Magic Mirror via the script uses pm2 to run a script at /home/pi/MagicMirror/run-start.sh. You can follow the instructions above to create your own script to run Magic Mirror in serveronly mode and switch between the two as you see fit.

    pm2 stop MagicMirror
    pm2 start mm_so
    

    and so on and so forth. Do keep in mind that running the MagicMirror process with the interface enabled includes the web server. So your options are 1) full magic mirror with web server, and 2) web server only.


Log in to reply