MagicMirror² v2.14.0 is available! For more information about this release, check out this topic.

MagicMirror freezes my pi

  • I was doing my setup for my Mirror and suddenly the mirror stopped loading. Everything freezes… I have to kill electron in the task manager to unfreeze my pi.
    So I tried reverting to my previous magic mirror setting that was ok before. Same bug. I updated rasbian, erased all magic mirror and reinstalled again, same bug.
    Every time I have to kill the 4 electron task in my task manager. No error shows up when I do the npm start. How can I solve this?

  • Module Developer

    @mariecbilodeau what do you see on the screen if it freezes. A blank screen or a screen that isn’t updating?

    Mine went blank but was due to the screensaver. It should be disabled.

  • Magic mirror doesn’t even load… I tried to erase everything and do the complete setup tutorial on the forum, it still does the same. I have to do ctrl+alt+del and kill electron for it to unfreeze
    0_1533775715948_Capture d’écran 2018-08-08 à 20.47.32.png image url)

  • This is the error log I have

    0 info it worked if it ends with ok
    1 verbose cli [ ‘/usr/bin/node’, ‘/usr/bin/npm’, ‘start’ ]
    2 info using npm@6.3.0
    3 info using node@v9.11.2
    4 verbose run-script [ ‘prestart’, ‘start’, ‘poststart’ ]
    5 info lifecycle magicmirror@2.4.1~prestart: magicmirror@2.4.1
    6 info lifecycle magicmirror@2.4.1~start: magicmirror@2.4.1
    7 verbose lifecycle magicmirror@2.4.1~start: unsafe-perm in lifecycle true
    8 verbose lifecycle magicmirror@2.4.1~start: PATH: /usr/lib/node_modules/npm/node_modules/npm-lifecycle/node-gyp-bin:/home/pi/MagicMirror/node_modules/.bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/local/games:/usr/games
    9 verbose lifecycle magicmirror@2.4.1~start: CWD: /home/pi/MagicMirror
    10 silly lifecycle magicmirror@2.4.1~start: Args: [ ‘-c’, ‘sh’ ]
    11 silly lifecycle magicmirror@2.4.1~start: Returned: code: 137 signal: null
    12 info lifecycle magicmirror@2.4.1~start: Failed to exec start script
    13 verbose stack Error: magicmirror@2.4.1 start: sh
    13 verbose stack Exit status 137
    13 verbose stack at EventEmitter. (/usr/lib/node_modules/npm/node_modules/npm-lifecycle/index.js:304:16)
    13 verbose stack at EventEmitter.emit (events.js:180:13)
    13 verbose stack at ChildProcess. (/usr/lib/node_modules/npm/node_modules/npm-lifecycle/lib/spawn.js:55:14)
    13 verbose stack at ChildProcess.emit (events.js:180:13)
    13 verbose stack at maybeClose (internal/child_process.js:936:16)
    13 verbose stack at Process.ChildProcess._handle.onexit (internal/child_process.js:220:5)
    14 verbose pkgid magicmirror@2.4.1
    15 verbose cwd /home/pi/MagicMirror
    16 verbose Linux 4.14.61-v7+
    17 verbose argv “/usr/bin/node” “/usr/bin/npm” “start”
    18 verbose node v9.11.2
    19 verbose npm v6.3.0
    20 error code ELIFECYCLE
    21 error errno 137
    22 error magicmirror@2.4.1 start: sh
    22 error Exit status 137
    23 error Failed at the magicmirror@2.4.1 start script.
    23 error This is probably not a problem with npm. There is likely additional logging output above.
    24 verbose exit [ 137, true ]

  • I reinstalled raspbian and now everything works

  • How did you do that? I have the same Problem.

  • I reinstall with the restore mode at startup and I reinstall all my mirror from scratch

Log in to reply