MagicMirror² v2.5.0 is available! For more information about this release, check out this topic.

Segmentation Fault



  • Evening viewers,

    I had MM running fine on the 3B+, have got myself a Zero W and assume I have shot myself in the foot…

    I took the SD card out of the 3 and put it into the Zero. Initially I had issues getting the keyboard and mouse to work, after much research I added a USB hub with it’s own power supply but this brought with it boot issues. I still am not sure of the why.
    Ultimately it booted into Raspbian. I opened a terminal, changed directories to the Magic Mirror but when I typed npm start I got a Segmentation fault.

    Am I right in thinking there’s a difference between the code for the Zero vs the 3?

    Any and all help gratefully accepted.

    Cheers,
    Rob



  • The drivers in the 3B+ OS are not compatible with older PIs
    Thus the SD card or image from the 3B+ will not work in the Zero W



  • Thanks Tuiceman,

    I spent much of yesterday afternoon and evening online, looking for an answer and didn’t come up with anything but a reinstall. I like to know the why for next time and the answer just may help someone else out in the same situation.

    I’ll put this card back into the 3B+ and start with a fresh card/install then report back in this thread.

    Cheers,
    Rob



  • As I’ve yet to install Magic mirror I’m not sure if there is a backup option.
    (still in the research stage)
    If there is this would make importing Magic mirror setups to another device. Simply install MM on the new device and then restore a backup.



  • Editing the Config file is pretty simple once you’ve done it once and shouldn’t take 5 minutes, depending upon how many and how complex you get with the modules.