MagicMirror² v2.5.0 is available! For more information about this release, check out this topic.

Conncting to MM from outside



  • Hi,
    I have installed the memo-module. In order to send URL’s to the MM I have to be able to contact my MM from my PC.

    When I Enter the URL In a Internet Explorer it says that it can’t reach this page and make sure the webaddress is correct.

    However I am able to ping the address from DOS.

    In the config-file I have written this:
    Port: 8080,
    IpWhitelist: [],

    So it should be quite Open!

    I also updates MM to newest version.

    Anyone have an idea?


  • Module Developer

    Try:

    var config = {
    	address: "0.0.0.0",
    	port: 8080,
    	ipWhitelist: [],
    

    or

    var config = {
    	address: "localhost",
    	port: 8080,
    	ipWhitelist: [],
    


  • @mykle1
    Thank you for your reply.
    Unfortunately it doesn’t work.

    I am still not able to write

    http://192.168.1.191:8080/

    In Internet Explorer



  • @mykle1

    Ohh, I think it is a upgrade problem with the mm.
    It is not possible to access the mm anymore from outside according to the last two comments.

    https://forum.magicmirror.builders/topic/5025/can-t-access-magic-mirror-via-http/10


  • Module Developer

    @janne

    If that is the case then you can always install an earlier version of MM. I would wait a bit to see if someone else has a solution for you. I’m pretty sure that issue was resolved or a work-around was found. Try doing a forum search for whiteListing.



  • Just to close the topic.
    I can’t connect with Internet Explorer. But I can with Chrome.

    Don’t know why, but I am a step closer to my goal.

    Hope it can help other magic Mirror builders.



  • I think I’ve been doing the same recently but I wanted to clarify what you meant by outside. The post and replies appear to assume you mean the local LAN (home network). Is this what you mean or are you trying to access this from a remote device or mobile not connected to you home WiFi.

    If it the first, then I would confirm that I am using the same setting.

    var config = {
    address: “0.0.0.0”,
    port: 8080

    If this is remotely access from another domain, you will need to know your internet providers IP address for your router and setup your route access rules/forwarding.



  • @graham-rich
    Hi,
    Actually I tried local LAN and I also set up a fixed ip in router and tested it from another LAN. Same problem and same fix.



  • @graham-rich said in Conncting to MM from outside:

    var config = {
    address: “0.0.0.0”,
    port: “8080” // added quotes to port: “8080” to correctly reflect my version
    // Not sure what your ipWhitelist is saying. For a test set it to
    ipWhitelist: [], //You will want to tie this down a little later to prevent it from being too open. Something like [“192.168.1.1”] if you know you local IP address should help once you got it working



  • I assume you have connected to your magicmirror via a terminal connection before to make sure its on the LAN and that you are using the same IP address with 8080 at the end. EG http:192.168.1.44:8080