Please help



  • Hi folks, I have a problem with the installation. I use a raspberry pi2 and have only made the configuration for the raspi and since I could z.b. Do not save the lxde since it would not exist. The same also with lightdm.conf. Then I have carried out the automatic installation for magicmirror2 what has worked so far. End to the end run display =: 0 non start? what do I have to do now? Is not an experienced programmer and now I do not know what I must push. At the moment, he does not show a mirror. I am using jessie lite. Please do not know any more. Sorry for the english that is google translated. I am from Germany and my English is not so good



  • Hi @moris, i’m sorry nobody else has responded.

    The automatic Magicmirror2 installation should have done everything necessary. You might need to rotate the screen. If you need to do this, just type sudo /boot/config.txt and put rotate_display=1 at the end. If it all looks okay already, don’t bother with this!

    to run the Magic mirror, make sure you are in the Magicmirror directory:
    cd MagicMirror
    You will need to make a file in the config folder, called config.js. There is a config.js.sample you can use. Just use cp config/config.js.samaple config/config.js to copy it to the file that is needed

    then type:
    npm start
    and the mirror should start :)

    Hallo @moris, es tut mir leid, dass niemand sonst reagiert hat.

    Die automatische Magicmirror2 Installation sollte alles Notwendige getan haben. Möglicherweise müssen Sie den Bildschirm drehen. Wenn Sie dies tun müssen, geben Sie einfach sudo /boot/config.txt und setzen rotate_display = 1 am Ende. Wenn alles schon okay aussieht, kümmere dich nicht darum!

    Um den Magic-Spiegel auszuführen, stellen Sie sicher, dass Sie sich im Magicmirror-Verzeichnis befinden:
    cd MagicMirror
    Sie müssen eine Datei im config-Ordner namens config.js erstellen. Es gibt eine config.js.sample, die Sie verwenden können. Verwenden Sie einfach
    cp config / config.js.samaple config / config.js
    um es in die Datei zu kopieren, die benötigt wird

    Dann geben Sie ein:
    npm start
    Und der Spiegel sollte beginnen :)


  • Module Developer

    Yes any issues please post them… many here would be glad to help! It’s a pretty cool thing to see it running the first time :)

    Thanks @darrene !



  • Many thanks I will test. The best I do it all from again so everything works out. With display Rotate I had already tried had I just not how I start the mirror. Then starts always in the mirror mode or must I always start with the command?


  • Module Developer

    You can start manually [which I personally prefer] using ‘npm start’ OR you can have it start automatically when the pi boots up using pm2… either way.

    Most prefer pm2 as if you have a power outage etc and the pi restarts the mirror restarts too… I just prefer the manual method well actually because I’m a dinosaur… LOL



  • For quick reference, the guide to using pm2 to automatically start the mirror process can be found here.

    I remember having trouble getting the UI displayed on my Raspberry PI 2, but I can’t remember what I did specifically to get it up and running. Assuming you are using a keyboard & mouse connected directly to the Pi, try this:

    • Start the Pi’s graphical interface (if it is not already running) by entering startx. You should eventually see a desktop, with a mouse cursor, menu, etc.
    • Open a terminal window using the Menu in the upper left.
    • In that terminal window, type cd ~/MagicMirror followed by npm start.

    That should at least give you your interface. If you are using SSH to issue commands to your mirror remotely, try the following:

    • Once you log into the Pi, navigate to the Magic Mirror directory like so: cd ~/MagicMirror
    • Start the magic mirror and specify that you want it to display on the monitor attached to the Pi: DISPLAY=:0 npm start

    It has been a while since I was playing around with my RPi 2. I think these will help.



  • @darrene I have it reinstalled and exactly according to your guidance held. I am in the MagicMirror folder and wants to insert config.js, he gives me the following:
    Pi @ raspberrypi: ~ $ cd MagicMirror
    Pi @ raspberrypi: ~ / MagicMirror $ cp config / config.js.samaple config / config.js
    Cp: ​​target ‘config.js’ is not a directory
    Pi @ raspberrypi: ~ / MagicMirror $

    And I give afterwards npm start a he gives me the following error message raus:
    Pi @ raspberrypi: ~ / MagicMirror $ npm start

    Magicmirror@2.0.0 start / home / pi / MagicMirror
    Electron js / electron.js

    / Home / pi / MagicMirror / node_modules / electron-prebuilt / dist / electron: errorWhite loading shared libraries: libgtk-x11-2.0.so.0: Can not open sharedObject file: No suchfile or directory

    Npm ERR! Linux 4.4.26-v7 +
    Npm ERR! Argv “/ usr / bin / nodejs” “/ usr / bin / npm” "start"
    Npm ERR! node v6.9.1
    Npm ERR! npm v3.10.8
    Npm ERR! file sh
    Npm ERR! code ELIFECYCLE
    Npm ERR! errno ENOENT
    Npm ERR! syscall spawn
    Npm ERR! Magicmirror@2.0.0 start: electron js / electron.js
    Npm ERR! spawn ENOENT
    Npm ERR!
    Npm ERR! Failed at the magicmirror@2.0.0 start script ‘electron js / electron.js’.
    Npm ERR! Make sure you have the latest version of node.js and npm installed.
    Npm ERR! If you do, this is most likely a problem with the magicmirror package,
    Npm ERR! Not with npm itself.
    Npm ERR! Tell the author that this fails on your system:
    Npm ERR! Electron js / electron.js
    Npm ERR! You can get information on how to open an issue for this project with:
    Npm ERR! Npm bugs magicmirror
    Npm ERR! Or if you are not available, you can get their info via:
    Npm ERR! Npm owner ls magicmirror
    Npm ERR! There is probably additional logging output above.

    Npm ERR! Please include the following file with any support request:
    Npm ERR! /home/pi/MagicMirror/npm-debug.log
    Pi @ raspberrypi: ~ / MagicMirror $

    Synonymous rotate_display =: 1 in config.txt entered. Since nothing has done synonymous no turning the display.
    Startx he made garnix. Something I’m doing wrong. It did with ssh and once without ssh



  • @moris said in Please help:

    Pi @ raspberrypi: ~ $ cd MagicMirror
    Pi @ raspberrypi: ~ / MagicMirror $ cp config / config.js.samaple config / config.js
    Cp: ​​target ‘config.js’ is not a directory
    Pi @ raspberrypi: ~ / MagicMirror $

    There’s a problem in your second command. There should be no space between config and the slash. There needs to be a period at the end of sample. It should read like so: cp config/config.js.sample config/config.js

    That line breaks down into command-source-destination. “Copy”-“sample file”-“destination file”. cp config/config.js.sample config/config.js



  • @Moris, when you use the copy (cp) command, I think you have spaces where you shouldn’t.
    if you are in the MagicMirror folder, the command should be;
    cp(space)config/config.js.sample(space)config/config.js

    it is possible to use to auto-complete the text where a file or folder exists if you want to.
    I am not sure why you are getting the Npm ERR! messages. I’m hoping someone else can help here. Are you using npm start on the pi locally or are you SSH’ing into it? I’ve only ever started mine when I am on the Pi itself.

    Edit: @bhepler is a faster typer than me! :)

    your /boot/config.txt should only have =1 and not =:1 for the display_rotate command. Here is an example;

    # For more options and information see
    # http://www.raspberrypi.org/documentation/configuration/config-txt.md
    # Some settings may impact device functionality. See link above for details
    
    # uncomment if you get no picture on HDMI for a default "safe" mode
    #hdmi_safe=1
    
    # uncomment this if your display has a black border of unused pixels visible
    # and your display can output without overscan
    #disable_overscan=1
    # uncomment the following to adjust overscan. Use positive numbers if console
    # goes off screen, and negative if there is too much border
    #overscan_left=16
     #overscan_right=16
    #overscan_top=16
    #overscan_bottom=16
    
    # uncomment to force a console size. By default it will be display's size minus
    # overscan.
    #framebuffer_width=1280
    #framebuffer_height=720
    
    # uncomment if hdmi display is not detected and composite is being output
    #hdmi_force_hotplug=1
    
    # uncomment to force a specific HDMI mode (this will force VGA)
    #hdmi_group=1
    #hdmi_mode=1
    
    # uncomment to force a HDMI mode rather than DVI. This can make audio work in
    # DMT (computer monitor) modes
    #hdmi_drive=2
    
    # uncomment to increase signal to HDMI, if you have interference, blanking, or
    # no display
    #config_hdmi_boost=4
    
    # uncomment for composite PAL
    #sdtv_mode=2
    
    #uncomment to overclock the arm. 700 MHz is the default.
    #arm_freq=800
    
    # Uncomment some or all of these to enable the optional hardware interfaces
    #dtparam=i2c_arm=on
    #dtparam=i2s=on
    #dtparam=spi=on
    
    # Uncomment this to enable the lirc-rpi module
    #dtoverlay=lirc-rpi
    
    # Additional overlays and parameters are documented /boot/overlays/README
    
    # Enable audio (loads snd_bcm2835)
    dtparam=audio=on
    display_rotate=1
    

    Hope that helps!



  • This is really fast here with answers. respect. I have no space between config and slash made that is so created when copying from the text. I wrote exactly as you showed it nevertheless, he says there is no folder available. But I see the sample I wrote samaple the whole time maybe this could be the error? Npm start I have with and without ssh tested in the cd MagicMirror and with both the same error. Has what with the config.js to do because it was not?


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.