MagicMirror² v2.5.0 is available! For more information about this release, check out this topic.

MMM-DVB



  • > sudo npm install
    
    > phantomjs-prebuilt@2.1.16 install /home/pirate/magic_mirror/modules/MMM-DVB/node_modules/phantomjs-prebuilt
    > node install.js
    
    PhantomJS not found on PATH
    Unexpected platform or architecture: linux/arm
    It seems there is no binary available for your platform/architecture
    Try to install PhantomJS globally
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: phantomjs-prebuilt@2.1.16 (node_modules/phantomjs-prebuilt):
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: phantomjs-prebuilt@2.1.16 install: `node install.js`
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: Exit status 1
    
    added 2 packages from 5 contributors and audited 1677 packages in 16.303s
    found 16 vulnerabilities (10 low, 6 high)
    

    Ich bekomme das Modul nicht zum laufen. Was kann ich tun?



  • @renedd said in MMM-DVB:

    PhantomJS

    Nach der Installation von PhantomJS für ARM (Raspi) wird der Installationsvorgang angeschoben. Leider bleibt er mit einem minimatch Fehler hängen.

    High          │ Regular Expression Denial of Service                         │
    ├───────────────┼──────────────────────────────────────────────────────────────┤
    │ Package       │ minimatch                                                    │
    ├───────────────┼──────────────────────────────────────────────────────────────┤
    │ Patched in    │ >=3.0.2                                                      │
    ├───────────────┼──────────────────────────────────────────────────────────────┤
    │ Dependency of │ grunt-cssbeautifier [dev]                                    │
    ├───────────────┼──────────────────────────────────────────────────────────────┤
    │ Path          │ grunt-cssbeautifier > grunt > findup-sync > glob > minimatch
    

    Ein npm ls minimatch zeigt, dass noch ein paar alte Versionen herumgeistern. Nur wie bekomme ich diese geupdatet?

    ├─┬ grunt-cssbeautifier@0.1.9
    │ └─┬ grunt@0.4.5
    │   ├─┬ findup-sync@0.1.3
    │   │ └─┬ glob@3.2.11
    │   │   └── minimatch@0.3.0 
    │   ├─┬ glob@3.1.21
    │   │ └── minimatch@0.2.14  deduped
    │   └── minimatch@0.2.14 
    └── minimatch@3.0.4
    


  • @renedd said in MMM-DVB:

    Ich bekomme das Modul nicht zum laufen. Was kann ich tun?

    versuche, Phantomjs zu installieren …

    npm installiere Phantomjs @ latest -g

    npm install Phantomjs@latest-g



  • @renedd said in MMM-DVB:

    Nach der Installation von PhantomJS für ARM (Raspi) wird der Installationsvorgang angeschoben. Leider bleibt er mit einem minimatch Fehler hängen.

    Minimiere die Installation auf die gleiche Weise …

    npm minimate @ next -g installieren

    npm install minimatch@latest -g



  • Danke, leider bleiben die 3 Fehler:

    HypriotOS/armv7: pirate@black-pearl in ~/magic_mirror/modules/MMM-DVB
    $ sudo npm install
    audited 1806 packages in 16.763s
    found 8 vulnerabilities (5 low, 3 high)
      run `npm audit fix` to fix them, or `npm audit` for details
    

    … und die drei als High markierten Einträge betreffen noch immer die zu alte minimatch Version (s.o.).



  • @renedd said in MMM-DVB:

    und die drei als High markierten Einträge betreffen noch immer die zu alte minimatch Version (s.o.).

    Führe den Audit-Fix aus …

    npm-Prüfungsreparatur

    npm audit fix



  • Die Fehler bleiben 😞

    sudo npm audit fix
    up to date in 12.475s
    fixed 0 of 8 vulnerabilities in 1806 scanned packages
      8 vulnerabilities required manual review and could not be updated
    

    Übrigens, wenn ich npm install Phantomjs@latest-g ausführe, kommen ebenfalls Fehler:

    Unexpected platform or architecture: linux/arm
    It seems there is no binary available for your platform/architecture
    Try to install PhantomJS globally
    npm ERR! code ELIFECYCLE
    npm ERR! errno 1
    npm ERR! phantomjs@2.1.7 install: `node install.js`
    npm ERR! Exit status 1
    

    Deshalb habe ich die Version von hier https://www.bitpi.co/2015/02/10/installing-phantomjs-on-the-raspberry-pi/ genommen



  • @renedd said in MMM-DVB:

    Deshalb habe ich die Version von hier https://www.bitpi.co/2015/02/10/installing-phantomjs-on-the-raspberry-pi/ genommen

    Sie müssen ein Leerzeichen zwischen @latest & -g haben

    Hat dieser Prozess für Sie funktioniert?

    Läuft MM, um zu sehen, ob es funktioniert?

    Ich habe Fehler wie diese auftreten lassen, aber das hat nichts mit dem Programm zu tun

    Versuchen Sie auch, das System neu zu starten



  • @renedd

    Wenn Sie die npm-Prüfung (npm audit) ohne Korrektur durchführen, werden alle fehlerbehafteten Elemente angezeigt und Sie erfahren, wie Sie sie manuell beheben können



  • Das npm Audit zeigt für diese restlichen 8 Probleme keine Lösungsvorschläge mehr an. Es erfolgt nur der Hinweis, das der minimatch Fehler in Version > 3.0.2. behoben ist. Vielleicht liegt es auch daran, dass ich nur eine abgespecktes OS (HypriotOS) verwende und MM selbst als Dockercontainer läuft. MM läuft aber, die mitgelieferten Module funktionieren auch. Ich werde in den nächsten Tagen versuchen, andere zusätzliche Module zum laufen zu bringen, mal sehen ab das klappt.