MagicMirror² v2.6.0 is available! For more information about this release, check out this topic.

Anyone else experiencing issues after updating Raspbian (black screen and wifi dropping)



  • Hi guys,

    I have updated Raspbian yesterday and ever since my mirror runs for a few minutes and then the screen goes blank. Nothing is in the logs and electron is still running. When I restart it -occassionally- I get resolve errors for github and stuff like that. But pin g / curl and everything works fine via shell.

    edit: Webinterface is running. Could it be that the screensaver is active? I have always had it disabled in the LXDE and LXDE-pi config.

    Any ideas?

    KR,

    Stephan



  • Update: it seems all the xset options I set are now being ignored, manually disabling the screensaver brings the mirror back.

    Update2: It seems also the wifi connections now gets reset every couple of minutes which may cause the resolve error I saw earlier in the logs



  • Solution for screensaver blanking:

    add:

    @xset s noblank 
    @xset s off 
    @xset -dpms
    

    to:

    /home/pi/.config/lxsession/LXDE-pi/autostart
    

    Note: setting it in

     /etc/xdg/lxsession/LXDE-pi/autostart or /etc/xdg/lxsession/LXDE/autostart 
    

    did not work anymore, the user files take precedence.

    I don’t know why it changed with the latest Raspbian Update or what I did wrong, but if I don’t add the xset commands as above and check with

    DISPLAY=:0 xset -q
    

    the screensaver stays enabled. If you guys need to verify it is disabled, just run the above command and check if the following lines appear like that:

    Screen Saver:
      prefer blanking:  no    allow exposures:  yes
      timeout:  0    cycle:  600
    
    DPMS (Energy Star):
      Standby: 600    Suspend: 600    Off: 600
      DPMS is Disabled
    

    If blanking and timeout are yes and not 0 the screensaver is active (DPMS should also show disabled)



  • For Wifi Problems I added:

    iwconfig wlan0 power off
    

    to

    sudo nano /etc/rc.local
    

    now checking the output with

    iwconfig wlan0
    

    gives me:

    Power Management:off
    

    let’s see if it is solved.



  • @yep_DD
    Hi There Stephan, I have the same problem with the black screen.
    After start the MM runs for some time and then it just goes to a black screen.

    I added the 3 lines to the autostart file and checked if the timeout and prefer blanking are set to 0 and no… and they are!
    I’m running MM2 this moment on a 24" screen to see if it stays on.
    I’ll let it run for some time. Hope it stays on!

    THANKS for the tutorial.

    Kind regards Mike



  • @mwel1977 let me know if it worked :). Was it “600 and yes” before the change?



  • @yep_DD I don’t know what the values were before I changed it but the values are currently NOT “yes” but “0” and “no”. And I didn’t let the MagicMirror just sit there doing nothing yesterday…
    I was installing modules and testing them. 😇 😇
    But I need to solve a module error tonight so I’ll start the MagicMirror as soon as I get home so it can stay like that for about an hour. If it’s still on then it’s okay! 👍
    I’ll let you know!



  • @yep_DD the MagicMirror is running almost 4 hours strait on end now.
    I would call that: screensaver disabled!😉



  • i have the latest Stretch and no folder lxsession in /.config
    what now?

    Sorry, I found it

    Note: setting it in
    /etc/xdg/lxsession/LXDE-pi/autostart or /etc/xdg/lxsession/LXDE/autostart