MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

Problem: Magic Mirror Module MMM-pages/MMM-page-indicator



  • Hi I am having some problems getting the MMM-pages/MMM-page-indicator to work with my Magic Mirror. I have git cloned it all and install all the dependencies and finally copied it into the config.js file. However it still won’t work! could someone take a look at my config and see if I am doing anything wrong?https://bluestacks.vip/

    (from the end of the defaults)

    {
    
    module: 'MMM-Globe',
    
    position: 'top\_center',
    
    config: {
    
    	style: 'geoColor',
    
    	imageSize: 200,
    
    	ownImagePath:'',
    
    	updateInterval: 10\*60\*1000
    
    }
    },
    
    {
    
    module: 'MMM-OnScreenMenu',
    
    position: 'bottom_right',
    
    /* Valid positions: 'top_right', 'top_left', 'bottom_right', 'bottom_left' */
    
    config: {
    
    touchMode: true,
    
    menuItems: {
    
    monitorOff: { title: "Turn Off Monitor", icon: "television", source: "SERVER" },
    
    restart: { title: "Restart MagicMirror", icon: "recycle", source: "ALL" },
    
    refresh: { title: "Refresh MagicMirror", icon: "refresh", source: "LOCAL" },
    
    reboot: { title: "Reboot", icon: "spinner", source: "ALL" },
    
    shutdown: { title: "Shutdown", icon: "power-off", source: "ALL" },
    
    },
    
    enableKeyboard: true,
    
    }
    
    },
    
    ]
    modules: [
    
    {
    
    module: 'MMM-page-indicator',
    
    position: 'bottom_bar',
    
    config: {
    
    pages: 1,
    
    }
    
    }
    
    ]
    
    modules: [
    
    {
    
    module: 'MMM-pages',
    
    config: {
    
    modules:
    
    [[ "weatherforecast", "newsfeed", "MMM-Globe"],
    
    [ "calendar", "compliments" ]],
    
    excludes: ["clock", "currentweather", "MMM-page-indicator", "MMM-OnScreenMenu"],
    
    }
    
    }
    
    ]
    
    };
    
    /*************** DO NOT EDIT THE LINE BELOW ***************/
    
    if (typeof module !== "undefined") {module.exports = config;}
    

    Cheers


  • Module Developer

    @cjmaverick
    There are to many

    ]
    modules: [
    

    in your config.js.
    There should be only one time

    modules: [
    

    somewhere in the beginning of your config.js and one time

    ]
    

    near the end of config.js
    Greetings

    AxLED


Log in to reply