MagicMirror² v2.14.0 is available! For more information about this release, check out this topic.

Flickering in portrait mode

  • I am opening up a new topic because the previous one was closed, but not in a way that works for me. Please see this link for many details

    I have v2.5 running on an HDMI connection to a large flat panel TV. After some period of time, I get line flashing across the display. Before finding the thread above, I replaced the video cable, then the PI itself, and finally the monitor, all with no success. Finally, I used a new memory card, brand new Raspbian install, MM installation and added only DarkSkyHourly for my weather… Same problem.

    I am running the fake driver as described in other threads for portrait mode, all updates (prior to the 2.6.0). I wanted to eliminate the OS and hardware, so ran a 10 hour YouTube video without any issues, then restarted the MM and it failed in just a few hours. My next step is doing the update to 2.6 since all the issued noted have been associated with 2.5.x, but any help would be MUCH appreciated.

    @friedleif @NoEngN3rd @vemerge @dazza120

  • @lamachine I’ve had nothing but problems with the fake and full GL drivers I’ve had to disable both and revert to the normal drivers using the fake one saw my screen go black screen almost immediately, using the full GL driver saw MMM-voice malfunction, reverted back to the standard saw a slight increase in use of cpu and memory and an increase of temp, all of which are not really alarming as it’s all within spec, the restart mm cron job that I’ve got going every 12 hours keeps it so I can always see mm when I turn on the screen. My screen will also be in a bathroom but I’ll be using a Harmony hub to turn it on and off with google, as I’ve left the TVs 4 hour built in protection for burn in on, see if the monitor going off eases the pressure on the Pi and try switching back to the standard drivers and see

  • Module Developer

    Same here, if I’m not using the legacy driver, all hell breaks loose.

  • Update, the 2.6.0 does the same thing.

    From @dazza120 and @BKeyport , I will look further into using different drivers. If either of you can point me to where I can get instructions on installing lagacy or normal drivers, it will save me much searching and testing.

    I am also considering trying the server and web page route, even if it is on the same machine. This is because the long web page test with the youtube video didn’t fritz out on me.

    Still looking for clues (like which version of Rasbpian/MM/drivers did this problem start) so I can continue my search for a solution.

  • Module Developer

    sudo Raspi-config 

    Advanced Options -> GL Drivers -> Legacy.

    “legacy” and “normal” drivers are the same thing.

  • PROBLEM SOLVED ! ! ! Thanks @BKeyport for the really easy way to change the driver.

    My screen has been running 48 hrs with no problems. I don’t know if using the old drivers has any adverse impact, but this is all I am using this particular Pi for, so it doesn’t impact me (yet?).

    Many thanks for the advice. I am going to mark this thread as solved (as soon as I figure THAT out)

  • Module Developer

    No problem. The “adverse effect” is apparently more CPU use, but, as most MM projects are on single use Pi computers, there’s no issue IMO.

  • @lamachine you may find youll need to setup a Cron Job as Legacy taxes the Pi memory a little more and causes the temps to be higher a heatsink is a good addition all is still well within spec so nothing to worry about.

    I’ve got a fan on mine as well so when I have my monitor on which basically means I’m using the Pi and with that drops the Pi temp about 13c, when the Pi is just having the modules run in the background temps in a 20c room are about 46/47c, with the monitor powered up and playing with the Pi temps can go up another 10c so 56c still well within spec and 56c isn’t with the fan going.

  • Module Developer

    @dazza120 Course, I can report the opposite, with my setup. While I don’t have exact figures the one thing that seems to have happened is that my system isn’t triggering the temp. icon anymore now that I’m back on the normal driver.

    That being said, I’ve got a fan+heatsink on the way for the final setup, there’s no reason not to protect the pi.

Log in to reply