MagicMirror² v2.7.0 is available! For more information about this release, check out this topic.

I could not install MM2 in a new Raspberry pi 3+



  • First I clean installed raspbian full, then I started and I waited for the system to be updated.
    Restart and paste this code:
    bash -c “$(curl -sL https://raw.githubusercontent.com/MichMich/MagicMirror/master/installers/raspberry.sh)”

    After twenty seconds :

    Leyendo lista de paquetes… Hecho
    Installing helper tools …
    Leyendo lista de paquetes… Hecho
    Creando árbol de dependencias
    Leyendo la información de estado… Hecho
    build-essential ya está en su versión más reciente (12.3).
    curl ya está en su versión más reciente (7.52.1-5+deb9u9).
    git ya está en su versión más reciente (1:2.11.0-3+deb9u4).
    unzip ya está en su versión más reciente (6.0-21).
    wget ya está en su versión más reciente (1.18-5+deb9u2).
    El paquete indicado a continuación se instaló de forma automática y ya no es necesario.
    realpath
    Utilice «sudo apt autoremove» para eliminarlo.
    0 actualizados, 0 nuevos se instalarán, 0 para eliminar y 0 no actualizados.
    Check current Node installation …
    Node currently installed. Checking version number.
    Minimum Node version: v5.1.0
    Installed Node version: v8.11.1
    No Node.js upgrade necessary.
    Cloning MagicMirror …
    Cloning into ‘MagicMirror’…
    remote: Enumerating objects: 302, done.
    remote: Counting objects: 100% (302/302), done.
    remote: Compressing objects: 100% (268/268), done.
    remote: Total 302 (delta 34), reused 221 (delta 24), pack-reused 0
    Receiving objects: 100% (302/302), 615.65 KiB | 501.00 KiB/s, done.
    Resolving deltas: 100% (34/34), done.
    Cloning MagicMirror Done!
    Installing dependencies …
    bash: línea 112: npm: no se encontró la orden
    Unable to install dependencies!
    pi@raspberrypi:~ $

    Then stop…
    Could you help this “newbie”? Thanks in advance.
    Albert



  • Probably you need to install npm first. Search the forum. There are more posts about this error



  • This worked for me. Updating the npm to the latest. I have Raspberry pi 3+ running raspian stretch. Hope this helps.

    https://forum.magicmirror.builders/post/8412