MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

MMM-iFrame or MMM-iFrame-Ping show nothing since last update

  • Project Sponsor

    Hi everybody,

    Just recently updated MM from 2.4.0 to 2.7.1 including all modules.
    Unfortunately had issues with MMM-Remote-Control first but used the fixes described on Github.
    But both MMM-iFrame or MMM-iFrame-Ping don’t show anything.
    I used MMM-iFrame to show a live video stream from my frontdoor using another Pi with Motion and using a curl command to show the iFrame on the MM when movement was detected and hide it after a while. That worked perfectly. I also could use this via homekit and ask Siri to turn on the Frontdoor Cam for example.

    I can see via http://MyMMIP:8080/remote?action=MODULE_DATA that the state of “hidden” changes between “true” and “false” when I use MMM-Remote-Control from my Mac or iPhone or when i use the buttons (show/hide Module iFrame)
    But it shows nothing…

    Anybody here who has an iFrame up and running with MM 2.7.1.

    My other modules:
    MMM-iFrame-Ping or MMM-iFrame
    MMM-RandomPhoto or MMM-BackgroundSlideshow


  • Project Sponsor

    @BluP: Got additional information from the console:

    Resource interpreted as Document but transferred with MIME type multipart/x-mixed-replace: “”.
    main.js:210 Resource interpreted as Document but transferred with MIME type multipart/x-mixed-replace: “”.

    @alberttwong: can you give me a hint what needs to be adjusted?
    @cowboysdude : I’ve searched the forum and also github and saw that yiou once had issues with iframe as well…any hints from your side?

    Thx, Peter

  • Project Sponsor Module Developer

    @BluP Don’t really have any suggestions other then play with the settings.

  • @BluP open the developers window, ctrl-shift-i, then select the console tab, and scroll up to see any errors, red text

  • I do get this:

    [Error] Refused to execute http://ip:8080/modules/iFrameReload//iFrameReload.js as script because "X-Content-Type: nosniff" was given and its Content-Type is not a script MIME type.
    Error on loading script: – "modules/iFrameReload//iFrameReload.js"
    onerror — loader.js:190
    Refused to display '' in a frame because it set 'X-Frame-Options' to 'SAMEORIGIN'.

    What can I do about this?

  • Project Sponsor

    @sdetweil Hi Sam, I tried that and the I got warnings about MMM-iFrame:

    main.js:210 Resource interpreted as Document but transferred with MIME type multipart/x-mixed-replace: "".
    updateModuleContent	@	main.js:210
    (anonymous)	@	main.js:139
    updateDomWithContent	@	main.js:137
    (anonymous)	@	main.js:119
    Promise.then (async)		
    (anonymous)	@	main.js:118
    updateDom	@	main.js:109
    updateDom	@	main.js:518
    updateDom	@	module.js:358
    (anonymous)	@	MMM-iFrame.js:25

    The url is my other RasPi running Monitor displaying a video from my frontdoor.

    As I stated in my 1st post, all was good since I upgraded to 2.7.1… 😞
    Any more hints?
    Thx, Peter

  • Project Sponsor

    I finally got it working again!👍

    I did a full fresh installation on a new SD card with complete latest Raspian and new MM and all the modules I used before…and still the same behavior: MMM-IFrame showed nothing and I got the same warnings as mentioned below.

    Then I tried MMM-SmartWebDisplay by @AgP42 which finally displays my video stream again. (BTW: This also works with other URLs as described in the documentation)
    Many thanks for this module.👏

    For all having issues with MMM-iFrame, MMM-IFrame-Ping etc., try MMM-SmartWebDisplay.
    Don’t forget to do a NPM install in the module folder once the module is cloned.

    Thanks, Peter

Log in to reply