MagicMirror² v2.14.0 is available! For more information about this release, check out this topic.

Node Install Issues

  • I was able to get MM setup but then when I upgraded Node I’m now receiving the following error when doing

    sudo npm start

    Here is the error that is returned after I run this via Remote Desktop terminal

    pi@raspberrypi:~ $ cd MagicMirror
    pi@raspberrypi:~/MagicMirror $ sudo npm start

    magicmirror@2.7.1 start /home/pi/MagicMirror

    No protocol specified

    (electron:4538): Gtk-WARNING **: cannot open display: :10.0
    npm ERR! code ELIFECYCLE
    npm ERR! errno 1
    npm ERR! magicmirror@2.7.1 start: sh
    npm ERR! Exit status 1
    npm ERR!
    npm ERR! Failed at the magicmirror@2.7.1 start script.
    npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

    npm ERR! A complete log of this run can be found in:
    npm ERR! /root/.npm/_logs/2019-05-17T05_48_06_943Z-debug.log
    pi@raspberrypi:~/MagicMirror $

    Here is the log info:

    0 info it worked if it ends with ok
    1 verbose cli [ ‘/usr/bin/node’, ‘/usr/bin/npm’, ‘start’ ]
    2 info using npm@6.9.0
    3 info using node@v10.15.3
    4 verbose run-script [ ‘prestart’, ‘start’, ‘poststart’ ]
    5 info lifecycle magicmirror@2.7.1~prestart: magicmirror@2.7.1
    6 info lifecycle magicmirror@2.7.1~start: magicmirror@2.7.1
    7 verbose lifecycle magicmirror@2.7.1~start: unsafe-perm in lifecycle true
    8 verbose lifecycle magicmirror@2.7.1~start: PATH: /usr/lib/node_modules/npm/node_modules/npm-lifecycle/node-gyp-$
    9 verbose lifecycle magicmirror@2.7.1~start: CWD: /home/pi/MagicMirror
    10 silly lifecycle magicmirror@2.7.1~start: Args: [ ‘-c’, ‘sh’ ]
    11 silly lifecycle magicmirror@2.7.1~start: Returned: code: 1 signal: null
    12 info lifecycle magicmirror@2.7.1~start: Failed to exec start script
    13 verbose stack Error: magicmirror@2.7.1 start: sh
    13 verbose stack Exit status 1
    13 verbose stack at EventEmitter. (/usr/lib/node_modules/npm/node_modules/npm-lifecycle/index.js:3$
    13 verbose stack at EventEmitter.emit (events.js:189:13)
    13 verbose stack at ChildProcess. (/usr/lib/node_modules/npm/node_modules/npm-lifecycle/lib/spawn.$
    13 verbose stack at ChildProcess.emit (events.js:189:13)
    13 verbose stack at maybeClose (internal/child_process.js:970:16)
    13 verbose stack at Process.ChildProcess._handle.onexit (internal/child_process.js:259:5)
    14 verbose pkgid magicmirror@2.7.1
    15 verbose cwd /home/pi/MagicMirror
    16 verbose Linux 4.14.98-v7+
    17 verbose argv “/usr/bin/node” “/usr/bin/npm” “start”
    18 verbose node v10.15.3
    19 verbose npm v6.9.0
    20 error code ELIFECYCLE
    21 error errno 1
    22 error magicmirror@2.7.1 start: sh
    22 error Exit status 1
    23 error Failed at the magicmirror@2.7.1 start script.
    23 error This is probably not a problem with npm. There is likely additional logging output above.
    24 verbose exit [ 1, true ]

    Any help is appreciated. Thank you!
    -newbie raspberry pi girl / natacha

  • @Natacha now that u upgraded node, you have to go back and redo

    npm install

    in the MM folder and all module folders if they have a package.json file

  • Project Sponsor Module Developer

    @Natacha said in Node Install Issues:

    sudo npm start

    You should not be using sudo npm start

    Simply, npm start in your MagicMirror directory. 🙂

    Follow @sdetweil instructions first.

  • @Mykle1 good catch… didn’t see sudo

  • Project Sponsor Module Developer

Log in to reply