MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

Trouble with MMM-Remote-Control



  • Howdy!

    I’m trying to install MMM-Remote-Control onto my Raspberry Pi. I follow the instructions as written, but each time I past the code to my config file I get the following screen.

    0_1567228394786_ab22daba-71f8-4120-a5c9-7fe19afe1192-image.png

    Here is the module:

    {
        			module: "MMM-Remote-Control"
       				// uncomment the following line to show the URL of the remote control on the mirror
        				, position: 'bottom_left'
        				// you can hide this module afterwards from the remote control itself
        			config: {
            			customCommand: {},  // Optional, See "Using Custom Commands" below
            			customMenu: "custom_menu.json", // Optional, See "Custom Menu Items" below
            			showModuleApiMenu: true, // Optional, Enable the Module Controls menu
            			apiKey: "",         // Optional, See API/README.md for details
        				},
    		},
    

    What am I missing here? I must be simple, but I’ve been at it too long and my brain is now fried. Any help would be much appreciated.


  • Project Sponsor

      {
              module: "MMM-Remote-Control",
              // uncomment the following line to show the URL of the remote control on the mirror
             position: 'bottom_left',
                // you can hide this module afterwards from the remote control itself
              config: {
                  customCommand: {},  // Optional, See "Using Custom Commands" below
                  customMenu: "custom_menu.json", // Optional, See "Custom Menu Items" below
                  showModuleApiMenu: true, // Optional, Enable the Module Controls menu
                  apiKey: ""         // Optional, See API/README.md for details
                }
        },
    

  • Project Sponsor

    that should work



  • @Stoffbeuteluwe said in Trouble with MMM-Remote-Control:

    {
    module: “MMM-Remote-Control”,
    // uncomment the following line to show the URL of the remote control on the mirror
    position: ‘bottom_left’,
    // you can hide this module afterwards from the remote control itself
    config: {
    customCommand: {}, // Optional, See “Using Custom Commands” below
    customMenu: “custom_menu.json”, // Optional, See “Custom Menu Items” below
    showModuleApiMenu: true, // Optional, Enable the Module Controls menu
    apiKey: “” // Optional, See API/README.md for details
    }
    },

    @Stoffbeuteluwe
    thanks. I implemented your code and it did get rid of the config request, but it still doesn’t display the URL as mentioned in the instructions.


Log in to reply