Config.js example of MMM-Page-Selector & MMM-CalendarExt2 working together



  • Does anybody have a working config.js with MMM-Page-Selector & MMM-CalendarExt2 working together that I can use as an example? I can get them working individually with other modules but not together.

    Thanks



  • @Monty so, you have to create a page (in page selector), and then put the CalendarExt2 module on that page, right?

    then you can show that page or some other page by selecting the page



  • Hi,

    So yes I have MMM-Page-Selector selector working fine. I created pages: {PageOne, PageTwo} etc and I have various modules displaying correctly one the pages One and Two (Weather, Internet connection status and some other modules) Everything works perfectly as expected.

    E.g.

      {
        module: 'MMM-connection-status',
        header: "Internet Connection",
        position: 'top_right', // Or any valid MagicMirror position.
        pages: {"PageOne": "top_right"},
        config: {
            // See 'Configuration options' for more information.
        }
    },
    
    

    My problem is when I try and add MMM-CalendarExt2 calendars to one of the pages, nothing shows up. It’s just blank on the screen where the Ext2 calendar should show up but all the other modules still display fine.

    E.g. here is my Ext2 config (excuse the formatting)

    {
      module: 'MMM-CalendarExt2',
      config: {
          rotateInterval: 0,
          updateInterval:600*100,
    
        calendars : [
          {
            name: "My Calendar",
            url: '**removed***
            beforeDays: 6,
            afterDays: 6,
            scanInterval: 600*100
          },
        ],
        views: [
          {
            mode: "daily",
            slotCount: 1,
            filterPassedEvent: true,
    //        position: "top_left",
            pages: {"PageOne": "top_left"},
            hideOverflow:false,
            maxItems: "9",
          },
          {
            mode: "daily",
            slotCount: 2,
            filterPassedEvent: true,
    //        position: "top_center",
            pages: {"PageTwo": "top_center"},
            fromNow:+1,
          },
       ],
        scenes: [
          {
            name: "DEFAULT",
          },
        ],
      },
    },
    


  • @Monty if you open the developers window, ctrl-shift-i on the mirror keyboard, select the tab labeled console, and scroll up, do you see any errors…

    you can also filter that console by placing part of the module name in the filter field (ext for example)



  • That’s quite handy, thanks. I don’t see any obvious issues in the logs. The only issues are related to OpenWeather long forecast and Electron running on an insecure port (nothing to do with this problem) Everything else seems fine.



  • @Monty I have the same problem with CalendarExt. Try viewing the mm using a browser, this caused my calendar to show up on mm and in the browser. Not the answer but might lead you to a solution.

    Keith



  • @Keith Thanks for the response. I have tried with browser and even after allowing everything in the whitelist it still doesn’t allow connections via the browser (connection refused) Similar to other peoples experiences on the forum.

    I will raise an issue on the Github page and refer back to here.



  • @Monty what is the setting in config.js for address:



  • I had the whitelist as [] which supposedly allows everything. I just changed it to this:

    ipWhitelist: ["::fff:0.0.0.0/1", "::fff:128.0.0.0/2", "::fff:192.0.0.0/3", "::fff:224.0.0.0/4", "127.0.0.1", "::ffff:127.0.0.1", "::1"],
    

    That works and I am able to browse localhost. I think it’s a different issue to you though because Ext2 still doesn’t show for me in the browser.

    Thanks



  • @Monty but u didn’t answer on address: you answered on whitelist.

    if the address is ‘localhost’, then only apps on this same machine can connect
    whitelist is another problem. leave it open until u solve the problems…

    	address: "", // Address to listen on, can be:
    	                      // - "localhost", "127.0.0.1", "::1" to listen on loopback interface
    	                      // - another specific IPv4/6 to listen on a specific interface
    	                      // - "", "0.0.0.0", "::" to listen on any interface
    	                      // Default, when address config is left out, is "localhost"
    	port: 8080,
    	ipWhitelist: [],