MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

a new problem with fhem



  • o.k. thanks all for the good job to me. I will always better in Magic Mirror. Now i have installed the fhem module with:

    cd ~/MagicMirror/modules
    git clone https://github.com/BenRoe/MMM-FHEM
    
    without npm install
    

    then i go to the config an i put this into:

    {
        module: 'MMM-FHEM',
        position: 'bottom_bar',
        config: {
          host: 'my IP',
          port: '8083',
          https: false,
          devices: [
                      { deviceName: 'Temperatur_Feuchte_Speicher',
                        deviceReadings: [
                                          { name: 'temperature', icon: 'wi wi-thermometer', suffix: '°' },
                                          { name: 'humidity', icon: 'wi wi-humidity', suffix: '%' },
                                        ],
                      },
                  
                    ],
        },
      },
    

    this is the device name of my sensor
    but when i restart the mirror, my mirror is black on screen 😞


  • Project Sponsor

    @kusselin You must insert the IP-address of your FHEM in

    host: 'my IP',
    

    Check also if it is running on port 8083 or on another port.

    If ‘npm install’ is required by the author of the module then it is advisable to do so (at least that is required so in the README.MD on github)

    Just to make sure: This module is not supported anymore (as stated on the github repo).



  • Can’t spot a mistake at first glance. Does the mirror work if you deactivate the module? For example, with disabled: true,

    Kann auf den ersten Blick keinen Fehler entdecken. Funktioniert der Spiegel, wenn du das Modul deaktivierst? Z.B. mit disabled:true,



  • @Fozi said in a new problem with fhem:

    @kusselin You must insert the IP-address of your FHEM in

    host: 'my IP',
    

    Check also if it is running on port 8083 or on another port.

    If ‘npm install’ is required by the author of the module then it is advisable to do so (at least that is required so in the README.MD on github)

    Just to make sure: This module is not supported anymore (as stated on the github repo).

    Hi fozi, instead of IP NAS I of course wrote my IP 192.168.xxx.xx and the port is also 8083 standard


  • Project Sponsor

    @kusselin Have you deactivated the module like @thedoorsfanatic recommended? Alternatively you can also comment the module in config.js. Just to make sure that there are no other side-effects.

    /*
    ….
    …..
    …..
    */
    


  • Sorry, i Havent. Give me Time tomorrow please.



  • @thedoorsfanatic said in a new problem with fhem:

    disabled:true,

    yes than i can see the mirror again and i have the npm install in the fhem directory make.
    but so the mirror is not show again


  • Project Sponsor

    @kusselin said in a new problem with fhem:

    yes than i can see the mirror again and i have the npm install in the fhem directory make.
    but so the mirror is not show again

    If the mirror is working again after deactivating the module, then remove the module from the /modules directory and re-install it from scratch.

    $ sudo rm -R MMM-FHEM
    $ git clone https://github.com/BenRoe/MMM-FHEM
    $ cd MMM-FHEM
    $ npm install
    


  • @Fozi said in a new problem with fhem:

    sudo rm -R MMM-FHEM

    whats that!!

    pi@raspberrypi:~ $  sudo rm -R MMM-FHEM
    rm: das Entfernen von 'MMM-FHEM' ist nicht möglich: Datei oder Verzeichnis nicht gefunden
    pi@raspberrypi:~ $ cd ~/MagicMirror/modules/MMM-FHEM
    pi@raspberrypi:~/MagicMirror/modules/MMM-FHEM $ sudo rm -R MMM-FHEM
    rm: das Entfernen von 'MMM-FHEM' ist nicht möglich: Datei oder Verzeichnis nicht gefunden
    pi@raspberrypi:~/MagicMirror/modules/MMM-FHEM $
    
    


  • @kusselin
    Du kannst den Ordner ja auch händisch über den Dateiexplorer löschen


Log in to reply