MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

How I got my Magic Mirror working on a Raspberry Pi 0 (zero)

  • @Mar
    Hi there,
    I had the same problem and the I have realized that node serveronly was not launched.
    The problem is that the command :
    cd ~/MagicMirror was not working, so I have changed it for
    cd /home/pi/MagicMirror
    and that’s it.
    Hope this can help

  • OK, so i am trying this again on a Pi Zero W

    I got stuck on Step 4
    so I ran:

    sudo apt-get remove nodered
    sudo apt-get remove nodejs nodejs-legacy
    sudo apt-get remove npm   # if you installed npm
    sudo dpkg -i node_archive_armhf.deb
    sudo apt-get install -y build-essential python-dev npm

    then again on Step 5 i got a ton of these:

    pi@raspberrypi:~/MagicMirror $ sudo npm install
    npm WARN engine feedme@1.0.0: wanted: {"node":">=0.12"} (current: {"node":"0.10.29","npm":"1.4.21"})
    npm WARN engine grunt-eslint@19.0.0: wanted: {"node":">=4"} (current: {"node":"0.10.29","npm":"1.4.21"})
    npm WARN engine request@2.81.0: wanted: {"node":">= 4"} (current: {"node":"0.10.29","npm":"1.4.21"})
    npm WARN engine eslint@3.17.1: wanted: {"node":">=4"} (current: {"node":"0.10.29","npm":"1.4.21"})

    Are the updated steps or an Image that can be downloaded?

  • @bmarofsky
    I’m also trying to install Magic Mirror on a Pi Zero W.

    I think one reason for the problems might be that as far as I can tell

    sudo wget
    sudo dpkg -i node_latest_armhf.deb

    got me node v4.2.1 which is quite outdated (the regular installer of MM2 updates nodes if the version of node is below 5.1.0).
    I therefore tried to install a more recent version of node following the commands here
    However, the compilation of Magic Mirror worked neither with node 7.7.1 nor with node 6.9.1.

    Before I go into details, did anybody got Magic Mirror working on Raspberry Pi Zero W?
    Which node version (and npm version) did you use and how you he install it? Which browser did you use (I read that Midori has some problems)?

  • Module Developer

  • I could fix my issue with the blank screen by simply doing

    cd ~/MagicMirror/vendor
    npm install

    Then it seem to work (even with the node v 4.2.1). Nevertheless I will try to update to a more recent version of node, just to avoid other problems that are likely to exist in this old node version.

  • Hi! I have followed this guide step by step and so precisely, however I am still getting an error when I type in DISPLAY=:0 npm start through SSH. This is the output:

    pi@raspberrypi:~/MagicMirror $ DISPLAY=:0 npm start
    > magicmirror@2.1.1 start /home/pi/MagicMirror
    > sh
    /home/pi/MagicMirror/node_modules/electron/dist/electron: error while loading shared libraries: cannot open shared object file: No such file or directory
    npm ERR! Linux 4.4.50+
    npm ERR! argv "/usr/local/bin/node" "/usr/local/bin/npm" "start"
    npm ERR! node v4.2.1
    npm ERR! npm  v2.14.7
    npm ERR! file sh
    npm ERR! code ELIFECYCLE
    npm ERR! errno ENOENT
    npm ERR! syscall spawn
    npm ERR! magicmirror@2.1.1 start: `sh`
    npm ERR! spawn ENOENT
    npm ERR!
    npm ERR! Failed at the magicmirror@2.1.1 start script 'sh'.
    npm ERR! This is most likely a problem with the magicmirror package,
    npm ERR! not with npm itself.
    npm ERR! Tell the author that this fails on your system:
    npm ERR!     sh
    npm ERR! You can get their info via:
    npm ERR!     npm owner ls magicmirror
    npm ERR! There is likely additional logging output above.
    npm ERR! Please include the following file with any support request:
    npm ERR!     /home/pi/MagicMirror/npm-debug.log

    Any help on what to do to solve this would be greatly appreciated!

  • @longod

    I didn’t try your way of starting the MagicMirror. However, is there a reason that you don’t use the commands in the guide to start the MagicMirror (using the and startMidori scripts)? There is no DISPLAY=:0 npm start mentioned in this thread.

  • @randombullet i followed those steps but i got a error it says that he cannot connect with localhost: 8080 webpage?

  • have you tried just using “npm start” in ssh? That works for me.

  • @dantodd you mean every time i start my rasp on i need to type npm start?