MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

Magic Mirror will not boot but Pi will, Cache issue?



  • The pi will boot but Magic Mirror won’t. I believe I’m having issues with the cache. It was working for a long time but I have since relocated the mirror and it no longer boots the MM program. when I run npm start i get “no helper found for module” and when I try to update my MM program I get “you dont have enough space var/cache/apt/archives”. Any help would be appreciated as it ran quite well a while ago. Do the modules build up data after being run 24/7? I’m also not entirely sure what a cache is if anybody could help. Thanks.



  • @tkaauf32

    no helper for module is ok, if the module doesn’t have helper… but u may be out of space

    review /var/log for dusplicates of log files

    syslog.n (these are old, probably ok to delete)
    and syslog

    etc

    this might give u an idea where space is used

    du -a / 2>/dev/null | sort -n -r | head -n 10
    

    note that this starts at the root… I have a remote volume attached so it searches that too… ugh
    and it only shows the top 10… head -n 10, u can up that number… but mostly bet its the logs



  • So I am unsure why it was working a month ago but is not working now. Is it always going to run out of space? Do I need a bigger sd card? What exactly are the purposes of the log files?



  • @tkaauf32 the system keeps track of all kinds of things…

    i don’t know why now vs before… you would have to find the next newest log file and scan thru it to try to determine what (if anything) important is going on
    here is my list of files in /var/log

    alternatives.log  btmp             dpkg.log        lightdm        syslog       user.log
    apt               daemon.log       faillog         messages       syslog.1     user.log.1
    auth.log          daemon.log.1     fontconfig.log  messages.1     syslog.2.gz  wtmp
    auth.log.1        daemon.log.2.gz  kern.log        messages.2.gz  syslog.3.gz  Xorg.0.log
    auth.log.2.gz     daemon.log.3.gz  kern.log.1      messages.3.gz  syslog.4.gz  Xorg.0.log.old
    auth.log.3.gz     debug            kern.log.2.gz   mongodb        syslog.5.gz
    boot.log          debug.1          kern.log.3.gz   motion         syslog.6.gz
    bootstrap.log     debug.2.gz       lastlog         private        syslog.7.gz
    


  • @sdetweil do a df -k
    it will give u a quick look at used disk space

    /dev/root                30358348    6863684   22210168  24% /
    


  • 0_1577725102433_2b034e88-3f97-4120-9de1-0917fd88bb51-image.png Screen Shot 2019-12-30 at 10.58.00 AM



  • @tkaauf32 ok, disk is full…

    the du thing above should give u a clue where…



  • 0_1577725265087_95c0ffa2-6bf6-459a-9e75-d1ee858e6efa-image.png Screen Shot 2019-12-30 at 11.00.55 AM

    So this is what that displays. And I really don’t understand why it is taking up so much space because it worked previously. I don’t know what to remove to give more space?



  • @tkaauf32 thats only of your home folder… usually not a problem

    notice I had /

    du -a / 2>/dev/null | sort -n -r | head -n 10
    


  • Okay so after typing correctly (my apologies, im not very savvy in this)

    0_1577725523781_910bc738-b0da-4dea-96a3-1b1e1ecdf7ba-image.png

    Screen Shot 2019-12-30 at 11.04.44 AM


Log in to reply