MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

2.9 to 2.10 update error using lubuntu 18.04



  • Tried using update script, didn’t work.
    Tried using manual update using git pull, didn’t work.

    Error:
    minime@mini:~$ cd MagicMirror
    minime@mini:~/MagicMirror$ npm start

    magicmirror@2.10.0 start /home/minime/MagicMirror
    ./run-start.sh

    App threw an error during load
    Error: Cannot find module ‘module-alias/register’
    at Module._resolveFilename (internal/modules/cjs/loader.js:602:15)
    at Function.Module._resolveFilename (/home/minime/MagicMirror/node_modules/electron/dist/resources/electron.asar/common/reset-search-paths.js:35:12)
    at Function.Module._load (internal/modules/cjs/loader.js:528:25)
    at Module.require (internal/modules/cjs/loader.js:658:17)
    at require (internal/modules/cjs/helpers.js:20:18)
    at Object. (/home/minime/MagicMirror/js/app.js:15:1)
    at Object. (/home/minime/MagicMirror/js/app.js:283:3)
    at Module._compile (internal/modules/cjs/loader.js:711:30)
    at Object.Module._extensions…js (internal/modules/cjs/loader.js:722:10)
    at Module.load (internal/modules/cjs/loader.js:620:32)
    A JavaScript error occurred in the main process
    Uncaught Exception:
    Error: Cannot find module ‘module-alias/register’
    at Module._resolveFilename (internal/modules/cjs/loader.js:602:15)
    at Function.Module._resolveFilename (/home/minime/MagicMirror/node_modules/electron/dist/resources/electron.asar/common/reset-search-paths.js:35:12)
    at Function.Module._load (internal/modules/cjs/loader.js:528:25)
    at Module.require (internal/modules/cjs/loader.js:658:17)
    at require (internal/modules/cjs/helpers.js:20:18)
    at Object. (/home/minime/MagicMirror/js/app.js:15:1)
    at Object. (/home/minime/MagicMirror/js/app.js:283:3)
    at Module._compile (internal/modules/cjs/loader.js:711:30)
    at Object.Module._extensions…js (internal/modules/cjs/loader.js:722:10)
    at Module.load (internal/modules/cjs/loader.js:620:32)

    Tried posting log, too long.



  • @fatrgr how did you do the update?

    git pull??

    you also need to do

    npm install

    from the announcement
    https://forum.magicmirror.builders/topic/11899/v2-10-0

    ️ Note: This update uses new dependencies. Please update using the following command: git pull && npm install
    


  • @sdetweil Thanks, I missed the announcement, and didn’t show in my searches. npm install worked. Will check for announcements next time. Thanks for the hard work!!



  • @fatrgr in general there is a planned new release every 90 days


Log in to reply