MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

Help for a Novice....



  • Re: MMM-Bose-Soundtouch
    Hi there,

    As I like others are at home I thought I would give this MMM a go and first task was to see if I could sort out the Bose Module.

    I have never repeat never done anything like this before so please be patient 🙂

    I have entered the above lines into my config.js yet when I reboot my Pi I get nothing - not even the header?

    I went into Terminal and went to the modules part and then ran the GitHub clone within the ~/MagicMirror/modules location ( hope that is correct)?

    Any ideas why I see nothing at all folks?



  • @j-ason so, if you go back to the original config.js (copy the sample to config.js, save your current one first)

    does mirror come back up?



  • Hi Sam,

    The mirror works with the modules I have - calendar, calendar and time 🙂

    Its just the Bose one I get seem to get to work that is frustrating me tbh 😞
    I fi could figure out how to add a screenshot I would 🤔



  • @sdetweil Thanks for replying so quickly too 👏



  • @j-ason the forum posting pics is broken (still)… so u have to post them somewhere else

    black screen usually means some config or setup problem…

    open the developers window (ctrl-shift-i on the keyboard), and select the console tab,. and scroll up to see any errors (usually red text)

    u did not edit any module file, right, only the config.js…

    does the module have a package.json file, and if so, did u run npm install in the module folder?



  • @sdetweil Can I send you the screenshot? (email , WhatsApp ?)

    As I said I am way out of my depth tbh - only started this the other day and hoping it will make sense as I go along 🤞🏻

    All I have done is load Raspberry Jessie version, MM2 install with default calendar, time, weather - edit… Have managed to work around getting my Google calendar to work and change location to UK for calendar and weather settings…



  • @j-ason sure, send to same userid as here, at gmail.


  • Project Sponsor Module Developer

    @j-ason

    Looking at the documentation, I see the config sample entry does not have a comma after the last bracket. The config entry should look like this:

    {
    	module: "MMM-Bose-Soundtouch",
    	position: "top_right",   // see mirror setting for options
    	config: {          
    		updateInterval: 5, // every 5 seconds
    		apiBase: '192.168.xxx.xxx',
    	}
    },
    

    Notice the comma after the last curly bracket?

    Of course, @sdetweil has probably brought that to your attention already. 🙂



  • @Mykle1 the comma only matters IF this is the not the last module config entry…

    but blackscreen shouldn’t be because of this, you’d get a “create a config file” error


  • Project Sponsor Module Developer

    @sdetweil

    True, but it IS the most common mistake for beginners, or I am much mistaken. 🙂


Log in to reply