MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

Raspberry Pi 3B+ and 4 "No wireless interfaces found"



  • Story short. I had installed Raspbian [Full] 64bit via NOOBS on a Pi 4. later I had to use my Pi 3B+, as i couldn’t find the type-C charger. Worked fine. Today after half a year having the pi in the closet, i found out that the internet didn’t work on it. switched to pi 4. Same problem. If i hover the mouse over the wifi icon, I get the message “No wireless interfaces found”. Neither the Ethernet port or wifi works, however Bluetooth are able to turn on.
    I see that other people have this problem too, and as i only have installed MagicMirror, I thought it would be alright to post it here, to see if other found a solution other that format and reinstall raspbian.

    What I did try (without quotation marks, and after = is console output):
    “Sudo ifup wlan0” =
    wpa_suppliant: cannot read contents of /etc/wpa_suppliant/wpa_suppliant.config
    run-parts: /etc/network/if-pre-up.d/wpasuppliant exited with return code 1
    ifup: failed to bring up wlan0

    “sudo ifdown wlan0” =
    ifdown: interface wlan0 not configured

    “sudo rfkill” =
    ID TYPE DEVICE SOFT HARD
    0 wlan phy0 unblocked unblocked
    1 Bluetooth hci0 blocked unblocked

    I will keep updated on how it goes.



  • @Blauenfeldt are u sure this is 64 bit? Cause pi os is supposed to be64 bit & not ready yet.

    In the. Menu top left select preferences, interfaces I think, to turn on networking.



  • In Noobs the is one with “32 bit” at the end, and that’s not the one i have have installed. My raspbian version in Buster, if that helps.
    what I have:
    Camera Enabled
    SSH Enabled
    VNC Enabled
    SPI Disabled
    I2C Enabled
    Serial Port Disabled (greyed out)
    1-wire Disabled
    Remote GPIO Disabled

    I also can’t select Wifi Country code. It keeps forgetting it after clicking on ok
    If i do it through sudo raspi-config I get “Could not communicate with wpa_suppliant” followed with “There was an error running option I4 Change wi-fi Country”
    This is what I got, when I run: dmesg | grep brcmfmac
    Raspberry Pi 4(2).jpg
    Is this as it should be?
    Thanks for helping me with this.



  • I can try and take a picture in Noobs Recovery and upload it.



  • @Blauenfeldt I never use noobs



  • @Blauenfeldt
    install it without noobs. Noobs has given me problems in one way or another when I have used it. The issues range from a lot of things depending on what you are doing …

    Go get the raspbian desktop image and just use that … it is just as easy to install as noobs and more than likely you will have working wifi when finished.

    If you have another sd card (and dont want to erase your noobs one) just try it out on a second card… you will get it going.



  • I guess I have to do that.
    I have used a lot of time compiling and makeing things forward/backwards compatible python wise. Is there a way to save and transfer that?



  • Now that i look this post through, I saw that rfkill says “wlan”. Is it possible, that my Pi looks for wlan0 and not wlan, and therefore not being able to find it?



  • @Blauenfeldt rfkill?

    sudo ifconfig
    will list the network interfaces



  • I did some digging around the net, and kinda got wifi working again. Wifi itself works fine. I can do sudo iwlist wlan0 scan, and see surrounding wifi. However the drop-down list on the panel does not work.
    What i did to get my wifi working to this point was changing the /etc/network/interfaces file to

    auto lo
    iface lo inet loopback
    
    auto eth0
    iface eth0 inet dhcp
    
    auto wlan0
    allow-hotplug wlan0
    iface wlan0 inet dhcp
            wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
    

    I found out I had some spelling errors like .config instead of .conf and found a default Buster Wpa_supplicant.conf file

    here is my new Sudo ifconfig

    eth0: flags=4163  mtu 1500
            inet 192.168.87.198  netmask 255.255.255.0  broadcast 192.168.87.255
            inet6 fe80::dea6:32ff:fe20:55bf  prefixlen 64  scopeid 0x20
            ether dc:a6:32:20:55:bf  txqueuelen 1000  (Ethernet)
            RX packets 1775  bytes 510729 (498.7 KiB)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 1633  bytes 972722 (949.9 KiB)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    
    lo: flags=73  mtu 65536
            inet 127.0.0.1  netmask 255.0.0.0
            inet6 ::1  prefixlen 128  scopeid 0x10
            loop  txqueuelen 1000  (Local Loopback)
            RX packets 275  bytes 80411 (78.5 KiB)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 275  bytes 80411 (78.5 KiB)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    
    wlan0: flags=4163  mtu 1500
            inet 192.168.87.199  netmask 255.255.255.0  broadcast 192.168.87.255
            inet6 fe80::dea6:32ff:fe20:55c0  prefixlen 64  scopeid 0x20
            ether dc:a6:32:20:55:c0  txqueuelen 1000  (Ethernet)
            RX packets 20  bytes 2957 (2.8 KiB)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 32  bytes 5653 (5.5 KiB)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    

    Everything works, even ethernet, except for the wifi drop-down menu (shown below)
    Raspberry Pi 4(4).jpg
    If I hover the mouse over it it says “connection to dhcpcd lost”
    If I click on it, it says “No wireless interfaces found”
    Can not really find anymore answers to this problem.
    Have i disabled something somewhere?


Log in to reply