MagicMirror² v2.4.1 is available! For more information about this release, check out this topic.
Please read the release notes carefully since this update requires adjustments to your Raspberry Pi configuration!

MagicMirror fails to be started via SSH console



  • Hello,

    I installed MagicMirror according the guide from github. MagicMirror can be started without problems from the GUI terminal. But it fails to start if I am not using the GUI but a SSH console connection instead.

    Here is the command to start MagicMirror and the resulting error message.

    user@raspberrypi:~/MagicMirror $ DISPLAY=:0 npm start
    
    > magicmirror@2.1.0 start /home/user/MagicMirror
    > electron js/electron.js
    
    
    npm ERR! Linux 4.4.38-v7+
    npm ERR! argv "/usr/bin/nodejs" "/usr/bin/npm" "start"
    npm ERR! node v6.9.2
    npm ERR! npm  v4.0.5
    npm ERR! code ELIFECYCLE
    npm ERR! magicmirror@2.1.0 start: `electron js/electron.js`
    npm ERR! Exit status 1
    npm ERR!
    npm ERR! Failed at the magicmirror@2.1.0 start script 'electron js/electron.js'.
    npm ERR! Make sure you have the latest version of node.js and npm installed.
    npm ERR! If you do, this is most likely a problem with the magicmirror package,
    npm ERR! not with npm itself.
    npm ERR! Tell the author that this fails on your system:
    npm ERR!     electron js/electron.js
    npm ERR! You can get information on how to open an issue for this project with:
    npm ERR!     npm bugs magicmirror
    npm ERR! Or if that isn't available, you can get their info via:
    npm ERR!     npm owner ls magicmirror
    npm ERR! There is likely additional logging output above.
    
    npm ERR! Please include the following file with any support request:
    npm ERR!     /home/user/MagicMirror/npm-debug.log
    

    Here you find the log file mentioned in the error message: https://gist.githubusercontent.com/wewa00/c61b27dc4991e94ccc78880e25afaa89/raw/f94ec26139a7afd47add78fdc8c92b56cd45d103/npm-debug.log
    How can I get MagicMirror started from SSH console?

    Regards, wewa00


  • Module Developer

    @wewa00

    Shouldn’t Display=:0 come after npm start?



  • See here: https://github.com/MichMich/MagicMirror#manual-installation

    Important: npm start does not work via SSH, use DISPLAY=:0 nohup npm start & instead. This starts the mirror on the remote display.

    And if I execute DISPLAY=:0 nohup npm start &, I get the same error message, but logged to nohup.out.



  • @wewa00 what do you see on your display before starting up?
    (Text console or graphical)



  • Hello jag,

    my Raspberry is configured for Desktop boot (without Autologin). During boot I see the text console for some seconds but then I see the MagicMirror splash screen.



  • @wewa00 Have you tried enable auto login?
    Can be configured with raspi-config.