MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

Raspberry pi 4 no hdmi output after a while



  • So today after messing around with MMPM and GoogleAssistant, my monitor turned went blank, and the “no connection” appeared, and went to display the next active input.
    I use the HDMI input 1 with my Stationary PC and HDMI input with my Pi 4.
    Tried to switch back to my Pi, but got the “no connection”.
    I have tried switching HDMI inputs, but the hdmi from my Pi still show no connection. HDMI from my pc works fine.
    I then tried to connect via VNC, and had no problem. The “Screen configuration” still says 1920x1080 @ 60HZ, so no nothing weird there.
    I tried the tvservice -scommand and got this

    pi@MagicMirror:~ $ tvservice -s
    state 0xa [HDMI CUSTOM RGB lim 16:9], 1920x1080 @ 60.00Hz, progressive
    

    I don’t know what to do with that info, but hopes it helps. I have tried to google a little around, but didn’t find any definitive solution, that didn’t involve something I couldn’t see how it would help.
    I have seen some talk about the power supply. But I don’t think I have that issue, as I use an 3 amp power supply from TT Electronics.
    This problem also happens, if I use my Pi 4 on my 4k tv.



  • @Blauenfeldt have u powered off your pi, and back on.

    I suspect you caused the HDMI port to be turned off. tvservice -o or the vgencmd

    I know there have been folks reporting that things that worked fine on pi3, won’t power back on on Pi4.


  • Module Developer

    try to tunning /boot/config.txt in sudo mode.
    you can boost HDMI signal and force it at boot

    some command in terminal for RPI:

    • vcgencmd display_power

    results:

    1. display_power=0 -> screen off
    2. display_power=1 -> screen on
    • vcgencmd display_power 1
      -> force screen on

    • vcgencmd display_power 0
      -> force screen off


Log in to reply