MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

MMM-NOAA3



  • Hi Guys,

    following the downfall of another weather module i was using - “MMM-MyWeather” i am trying to install MMM-NOAA3.

    When i run MM i get the below error,

    [2020-10-27 21:19:39.201] [LOG]    Sockets connected & modules started ...
    [2020-10-27 21:19:39.287] [LOG]    Launching application.
    [2020-10-27 21:19:43.002] [LOG]    wu
    [2020-10-27 21:19:43.006] [ERROR]  Whoops! There was an uncaught exception...
    [2020-10-27 21:19:43.007] [ERROR]  Error: Cannot find module './providers/wu.js'
    Require stack:
    - /home/pi/MagicMirror/modules/MMM-NOAA3/node_helper.js
    - /home/pi/MagicMirror/js/app.js
    - /home/pi/MagicMirror/js/electron.js
    - /home/pi/MagicMirror/node_modules/electron/dist/resources/default_app.asar/mai                                                                                                                     n.js
    -
        at Module._resolveFilename (internal/modules/cjs/loader.js:627:15)
        at Function.Module._resolveFilename (/home/pi/MagicMirror/node_modules/elect                                                                                                                     ron/dist/resources/electron.asar/common/reset-search-paths.js:41:16)
        at Function.Module._resolveFilename (/home/pi/MagicMirror/node_modules/modul                                                                                                                     e-alias/index.js:49:29)
        at Function.Module._load (internal/modules/cjs/loader.js:531:27)
        at Module.require (internal/modules/cjs/loader.js:685:19)
        at require (internal/modules/cjs/helpers.js:16:16)
        at Class.getProviderFromConfig (/home/pi/MagicMirror/modules/MMM-NOAA3/node_                                                                                                                     helper.js:128:16)
        at Class.socketNotificationReceived (/home/pi/MagicMirror/modules/MMM-NOAA3/                                                                                                                     node_helper.js:38:34)
        at Socket. (/home/pi/MagicMirror/js/node_helper.js:112:11)
        at Socket.emit (events.js:200:13)
        at /home/pi/MagicMirror/node_modules/socket.io/lib/socket.js:528:12
        at processTicksAndRejections (internal/process/task_queues.js:82:9)
     {
      code: 'MODULE_NOT_FOUND',
      requireStack: [
        '/home/pi/MagicMirror/modules/MMM-NOAA3/node_helper.js',
        '/home/pi/MagicMirror/js/app.js',
        '/home/pi/MagicMirror/js/electron.js',
        '/home/pi/MagicMirror/node_modules/electron/dist/resources/default_app.asar/                                                                                                                     main.js',
        undefined
      ]
    }
    [2020-10-27 21:19:43.015] [ERROR]  MagicMirror will not quit, but it might be a                                                                                                                      good idea to check why this happened. Maybe no internet connection?
    [2020-10-27 21:19:43.016] [ERROR]  If you think this really is an issue, please                                                                                                                      open an issue on GitHub: https://github.com/MichMich/MagicMirror/issues
    

    Below is my config minus api keys

      {
         module: 'MMM-NOAA3',
     position: 'top_right',
         config: {
     	    provider: "weatherunlocked",       
     	    apiKey: "MY API KEY",  
     	    appID: "MY APP ID",  
     	    airKey: "MY API KEY", 
             css: "NOAA4",                  // THIS MUST CONTAIN A CSS STYLE NAME
     	userlat: "55.861790", //MUST HAVE BOTH
             userlon: "-3.827600",  //MUST HAVE BOTH
      }
          },
    

    I am at a complete loss with this one any help would be appreciated.

    Cheers
    Michael


  • Project Sponsor Module Developer

    @mmcghee said in MMM-NOAA3:

    I am at a complete loss with this one any help would be appreciated.

    Did you try it with another provider? I just loaded it up with openweather and it fired right up. I know this author and the amount of work it takes to maintain this module. I think he is working on a new version because NOAA3 is vulnerable if any of the providers changes their data



  • Hi,

    Yeah i tried it with Accuweather and still had the same. I’ll try it with openweather when i get home and see what happens.

    Thanks
    Michael


Log in to reply