MagicMirror² v2.14.0 is available! For more information about this release, check out this topic.

Search module for livecam / stream



  • @KamiSchami You can use this.

    {
    		module: "MMM-RTSPStream",
    		disabled: false, //false, true
    		position: "middle", 
    		config: {
    			autoStart: true,
    			rotateStreams: false,
    			rotateStreamTimeout: 20,
    			moduleWidth: 468,
    			moduleHeight: 320,
    			localPlayer: "omxplayer", // "omxplayer" or "ffmpeg", or "vlc"
    			remotePlayer: 'none',
    			showSnapWhenPaused: false,
    			remoteSnaps: false,
    			  stream1: {
    			  name: 'Ostseebad',
    			  url: 'https://cam01.binz-kabel.de/cam1.m3u8',
    			  protocol: "tcp",
    			  frameRate: 25,
    			  muted: true,
                              hwAccel: true,
                              width: 450,
                              height: 300,
    			},
    


  • @KamiSchami this part I meen

    			  stream1: {
    			  name: 'Ostseebad',
    			  url: 'https://cam01.binz-kabel.de/cam1.m3u8',
    			  protocol: "tcp",
    			  frameRate: 25,
    			  muted: true,
                              hwAccel: true,
                              width: 450,
                              height: 300,
    


  • Thanks, it was late yesterday. The camera was gray and night mode and my buttons are also gray, I have to check if it is brighter.



  • hi, it’s still over the button when i enlarge the module 🙈



  • @KamiSchami what am I doing wrong?
    for me MM starts but the whole screen remains black
    Can someone help me please?
    Is the MMM-RTSPStream module up to date? still works?

    Screenshot 2021-01-14 164536.png



  • @drx1984
    This one is working fine.
    De URL was wrong.

    {
    module: "MMM-RTSPStream",
    disabled: false, //false, true
    position: "middle", 
    config: {
    	autoStart: true,
    	rotateStreams: false,
    	rotateStreamTimeout: 20,
    	moduleWidth: 468,
    	moduleHeight: 320,
    	localPlayer: "omxplayer", // "omxplayer" or "ffmpeg", or "vlc"
    	remotePlayer: 'none',
    	showSnapWhenPaused: false,
    	remoteSnaps: false,
    	stream1: {
    	name: 'test-BUNNY',
    	url: 'rtsp://wowzaec2demo.streamlock.net/vod/mp4:BigBuckBunny_115k.mov',
    			  protocol: "tcp",
    			  frameRate: 25, 
    			  muted: true,
                              hwAccel: true,
                              width:  450,
                              height: 300,
    }
    }},
    


  • @JerryP unfortunately it still doesn’t work.
    Magic mirror starts but it just remains black and the terminal says that the module is not available?
    I have already copied the module into the modules folder with the command “git clone”.

    Screenshot 2021-01-14 222559.png



  • @drx1984
    Goodmorning,
    I think the module is not install correctly
    have you follow the instructions https://github.com/shbatm/MMM-RTSPStream

    You can also
    go into terminal.
    cd ~/MagicMirror/modules/MMM-RTSPStream
    git pull
    npm install

    If that i’s not working I can only suggest that you delete your current installation of the module and re-install it.


Log in to reply