MagicMirror² v2.4.1 is available! For more information about this release, check out this topic.
Please read the release notes carefully since this update requires adjustments to your Raspberry Pi configuration!

Basic configuration issues with compliments & calendar modules



  • Hi all,

    Some very simple things don’t work, I’m guessing it’s me so thanks for your patience 🙂 I’ve successfully installed MagicMirror and have been able to configure it to show my Google Calendar, as well as weather for my region. So far, so good.

    However, I could only get the compliments module to disappear by removing it from the config.js file. Adding disabled: true in the following manner (like it says here) does not seem to have any effect:

                    {
                            module: 'compliments',
                            position: 'lower_third',
                            disabled: 'true',
                            config: {
                                    }
                    },
    

    Then, when I configure the calendar, the maximumEntries seems to be respected but preventing fading or hiding the symbol before each entry does not work with this configuration:

                    {
                            module: 'calendar',
                            position: 'top_left',
                            header: 'Agenda',
                            config: {
                                    maximumEntries: '5',
                                    displaySymbol: 'false',
                                    fade: 'false',
                                    calendars: [
                                            {
                                                    url: 'https://URL.ics'
                                            }
                                    ]
                            }
                    },
    

    I hope anyone knows if I’m doing something wrong, and what?



  • @mh77 you have to type booleans without quotes

    disabled: true , fade: false and displaySymbol: false



  • Ah of course, that’s it. Thanks so much!

    I hadn’t thought of it, because when I used ‘onlyTemp’ in my currentweather module config, it worked when I entered ‘true’. But it also only shows the temperature when I enter ‘false’ there, so it somehow defaults to true if you enter it with any value between single quotes.

    Anyhow, thanks again!



  • @mh77 a string in javascript is handled as true, so 'false' => true