how to disable screensaver?



  • @lolobyte

    I tried this after I got home today and the package xscreensaver is not installed so this command failed.



  • @sgtwtf

    follow this install guide, you will find this entry’s: https://github.com/MichMich/MagicMirror/wiki/Jessie-Lite-Installation-Guide

    Disable the screensaver

    Go to LXDE-autostart config:

    sudo nano /etc/xdg/lxsession/LXDE/autostart

    add the following lines:

    @xset s noblank
    @xset s off
    @xset -dpms 
    

    Save and close, using the commands CTRL-O and CTRL-X.

    Go to lightdm.conf:

    sudo nano /etc/lightdm/lightdm.conf

    add the following lines:

    xserver-command=X -s 0 -dpms
    

    Reboot the raspberry pi:

    sudo apt-get install xscreensaver
    sudo apt-get remove xscreensaver
    sudo reboot
    


  • The commands were already added to those files. I installed xscreensaver and uninstalled and rebooted and no change.



  • @sgtwtf

    My solution was to install xscreensaver and use the desktop control panel to disable the screensaver.

    sudo apt-get install xscreensaver
    sudo reboot
    

    On reboot open the desktop start menu (via the GUI, not the terminal) and I think it’s Preferences > Screensaver Settings. There’s an option to set (and disable) the screensaver. It worked for me. :)



  • @in_a_days

    Thank you that worked like a charm!



  • @in_a_days
    Thanks for that easy solution, and as I havn’t installed Jessie-Lite, I tried your way to disable the screensaver.
    I do agree with @sgtwtf, it works like a charm :relaxed:
    Thank you !


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.