[MMM-Buttons] Not recognizing button presses



  • @istepgueu Tried that, also tried a reboot. Doesnt work on the screen connected to the pi, but still does when i access via a browser. Also when i access via a browser I see this show up in the logs “Initialize button power on PIN 5” but this line doesnt show up when restarting MM and accessing via the HDMI.



  • @Mar Ok
    1 - Your button is connected on PIN N°29 = GPIO 5 ?
    2 - Which type of button do you have ? It’s a Push button (Button that returns alone) or a button who stay ?

    Sorry for my english… i’m French 🙂



  • @istepgueu thank you, and not a problem of course. i can understand you perfectly fine.

    1. correct pin 29, bcm 5
    2. i have this type of 4 pin button. press to activate and returns to initial position when you let go (alt text)


  • @Mar Can you test this :

    1 - Reboot your Pi
    2 - If your mirror start automatically, stop it with “pm2 stop mm”
    3 - Execute the button.py script (adapt to GPIO5)
    4 - Start MM with “pm2 start mm”
    5 - Test if it’s working.



  • @istepgueu no change. the script is recognizing the press, and so is it through the browser on my laptop. But nothing on the HDMI screen attached to the pi.



  • @Mar
    It is completely strange this story. Have you ever managed to have alerts other than the module buttons on the HDMI?



  • @istepgueu yes im so stumped with this. its obviously working…just not on the instance on the hdmi monitor. Ive not used alerts before this, the only things ive attached to the pi are a pir sensor with a script on boot that turns my monitor on/off along with a few modules (tube status, wunderlist, and system stats) all of which are working fine.



  • @Mar
    Sorry but I have no idea … Maybe @Jopyth the creator of the module could help you?



  • @istepgueu Well thank you for trying to help, its much appreciated.



  • So seems like I only ever get to the “Initialize button power on PIN X” log statement when accessing the MM from a remote browser. Otherwise the pi doesnt hit this part of the script on its own.

    Only error I can see so far is this when loading midori from command line (though still initializes the pin via the browser so maybe midori doesnt like this line but chrome ignores it?

    ** Message: console message: http://localhost:8080/modules/MMM-Buttons//MMM-Buttons.js @86: SyntaxError: Unexpected token '('. Expected a ':' following the property name 'sendAction'.