Modules not showing up



  • Hey guys,
    I manually installed MagicMirror on my Pi Zero, but I’ve run into some trouble:
    My config file is formatted correctly, but no modules are showing up. If I comment all our and only do one at a time, the only module that shows up is clock.
    Any suggestions??
    Thanks.



  • hey guys, i just reply to this thread, because i’ve got exactly the same problem with my Rpi1 B!

    So i just copied the config.js.sample to config.js, rebooted theab pi and startet everything.
    Got a blank Screen only.

    after that i tried to remove every module and add “hello World”.
    It Worked.
    After that i tried to add module for module:
    When i add the compliments module i still see only my Hello World!
    After i added the clock. everything goes blank again. Anybody knows a reason why?

    here is my config.js so far

    var config = {
            port: 8080,
            ipWhitelist: ["127.0.0.1", [], "::ffff:127.0.0.1", "::1"], // Set [] to allow all IP addresses
                                                                   // or add a specific IPv4 of 192.168.1.5 :
                                                                   // ["127.0.0.1", "::ffff:127.0.0.1", "::1", "::ffff:192.168.1.5"],
                                                                   // or IPv4 range of 192.168.3.0 --> 192.168.3.15 use CIDR format :
                                                                   // ["127.0.0.1", "::ffff:127.0.0.1", "::1", "::ffff:192.168.3.0/28"],
    
            language: "de",
            timeFormat: 24,
            units: "metric",
    
            modules: [
                    {
                            module: "helloworld",
                            position: "top_left",
                            config: {
                                    text: "Hallo Welt!",
                            }
                    },
                    {
                            module: "compliments",
                            position: "lower_third",
                            anytime: [
                                     "Hey there sexy!"
                            ],
                    },
            ]
    
    };
    
    /*************** DO NOT EDIT THE LINE BELOW ***************/
    if (typeof module !== "undefined") {module.exports = config;}
    


  • @ROMSY probably you don’t have installed momentjs correctly



  • @strawberry-3.141
    i followed this instruction from the forum.
    Question is for me right now, where do i check if i installed it correctly?



  • @ROMSY in the magicmirror folder is a folder vendor which should have a folder node_modules and in there there has to be a momentjs folder



  • @strawberry-3.141

    pi@infoscreen:~ $ ls MagicMirror/vendor/
    package.json  vendor.js
    

    just checked the git… same structur in there. so what is the next step?



  • @ROMSY you have to run npm install



  • @strawberry-3.141
    everything is working now! Thanks a lot 🙂