MMM-Memo - Add some memos on your page and manage them through HTTP request

  • Banned

    Such a usefull topic,thanks

  • Banned

    This post is deleted!

  • @Crayyy same issue… did you find a fix?

  • ok… I installed this module…

    u define in the config.js a tag to identify acceptable incoming ‘memos’…

    once I did that I was able, in a browser to do
    and I got back
    and a memo appears on the mirror screen is my mirror ip address, and 8086 is the port in the config.js

    in config.,js I have

      address: "", // Address to listen on, can be:   
                            // - "localhost", "", "::1" to listen on loopback interface
                            // - another specific IPv4/6 to listen on a specific interface
                            // - "", "", "::" to listen on any interface
                            // Default, when address config is left out, is "localhost"
      port: 8086,
      ipWhitelist: [],   // allow anyone to connect

    if address:“localhost” then only from INSIDE the mirror machine is allowed to make connections to mirror application

    if I do this

    the response is

    {"status":"failed","error":"No 'memoTitle' given."}

    if I do this

    where memoTitle matches the value specified in config.js

            module: 'MMM-Memo',
            position: 'top_left',
            classes: 'default everyone',        // if using MMM-ProfileSwitcher module
            config: {
                // See 'Configuration options' for more information.
                memoTitle: "testing"

    then i get this

    {"status":"failed","error":"No 'item' given."}


    note to have multiple memo pages, you need to add the module to the config.js multiple times, with different memoTitle values…

    If you declare several modules in the config/config.js file, you will get several memo notes on your MagicMirror2 profile.

  • There needs to be a config switch to disable the showing of the pin. Like “showPin” which is set to true by default. I have a small mirror and the pin takes up a lot of vertical space.