MMM-Wunderground



  • Hello All,

    I am trying to get the Wunderground module to load on my mirror. When I start the mirror program from the command line it simply does not show up. I have cloned the data in the gitHub link and have added it to my config but it still does not show up.

    My Config:

    /* Magic Mirror Config Sample
     *
     * By Michael Teeuw http://michaelteeuw.nl
     * MIT Licensed.
     */
    
    var config = {
    	zoom: 1,
    	port: 8080,
    	ipWhitelist: ["127.0.0.1", "::ffff:127.0.0.1", "::1"],
    
    	language: 'en',
    	timeFormat: 12,
    	units: 'imperial',
    
    	modules: [
    		{
    			module: 'clock',
    			position: 'top_bar',
    			config: {
    					displaySeconds: false,
    					showDate: false
    					}
    		},
    		{
    			module: 'MMM-WunderGround',
    			position: 'top_third',
    			config: {
    					apikey: '--------------------',
    					pws: 'pws:KTXIRVIN10',
    					hourly: '1'
    					}
    		}
    	]
    
    };
    
    /*************** DO NOT EDIT THE LINE BELOW ***************/
    if (typeof module !== 'undefined') {module.exports = config;}
    
    

    When I start the Program in the terminal, it outputs this:

    pi@SmartScreen1:~/MagicMirror $ npm start

    magicmirror@2.1.0 start /home/pi/MagicMirror
    electron js/electron.js

    Starting MagicMirror: v2.1.0
    Loading config …
    Loading module helpers …
    No helper found for module: clock.
    Initializing new module helper …
    All module helpers loaded.
    Starting server op port 8080 …
    Server started …
    Connecting socket for: MMM-WunderGround
    MMM-WunderGround helper started …
    Sockets connected & modules started …
    Launching application.
    GET_WUNDERGROUND

    Thank you in advance for any help.


  • Module Developer

    @Chrispl2000

    You’re missing a comma on the second to last }. It should look like this }, Look how I changed it below

    {
    			module: 'MMM-WunderGround',
    			position: 'top_third',
    			config: {
    					apikey: '--------------------',
    					pws: 'pws:KTXIRVIN10',
    					hourly: '1'
    					}
    		},
    	]
    
    };


  • The extra comma didn’t change anything. I thought you only used a comma when there is another item behind it?


  • Module Developer

    @Chrispl2000

    That is true, but you are closing out the config at this point. Here is the end of my config. Notice the comma.

    {
    						title: "New York Times",
    						url: "http://www.nytimes.com/services/xml/rss/nyt/HomePage.xml"
    					},
    					{
                        				title: "BBC World News",
                        				url: "http://feeds.bbci.co.uk/news/world/us_and_canada/rss.xml"
                    			},
    				],
    				showSourceTitle: true,
    				showPublishDate: true
    			}
    		},
    	]
    
    };
    
    /*************** DO NOT EDIT THE LINE BELOW ***************/
    if (typeof module !== 'undefined') {module.exports = config;}
    

  • Module Developer

    If everything else is working then the error lies in the config entry for WonderGround.


  • Module Developer

    Here is my entry for WunderGround.

    {
    			disabled: f,
        			module: 'MMM-WunderGround',
        			position: 'top_right',
        			config: {
            		apikey: 'YOUR API KEY', // private
            		pws: 'pws:KNYNEWYO103',
    			currentweather: 0,
            		coloricon: true,
            		hourly: '1',
            		fctext: '1',
            		fcdaycount: "10",
            		fcdaystart: "0",
            		hourlyinterval: "2",
            		hourlycount: "1",
    			animationSpeed: 5000,
            		alerttime: 10000,
            		alerttruncatestring: "english:",
        			roundTmpDecs: 0,
        			UseCardinals: 1,
        			layout: "vertical",
    			windunits: "mph",
        			sysstat: "0"
    			}
    		},
    

  • Module Developer

    Wait! top_third is not valid. Try top_right


  • Module Developer

    Hover your mouse over my avatar to the left of my name and click chat



  • Great catch!!! I’m new to pretty much everything involved in programming this thing.


  • Module Developer

    @Chrispl2000
    No worries. If you have TeamSpeak I can help you more easily if you’d like


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.