mirroronthewall



  • Hi,
    I’m having trouble with my mirroronthewall module.
    It doesn’t seem to respond.
    Can anyone help me please?
    Regards,
    Arthur Ross



  • This post is deleted!


  • @johnnyboy said in mirroronthewall:

    If you can provide a little more information then the guys here may be able to help?
    Your set up, what you did and how you did it, what Pi you are using, ect, ect

    I’m using a pi 3 model b and followed the instructions set on the mirroronthewall(skill) github site. I managed to make alexa respond, but now nothing is displayed on the mirror when I ask her something. I may have sudo npm installed some things.
    Is there an easy workaround to have the mirror display youtube, google, etc?



  • This post is deleted!


  • https://github.com/joanaz/MMM-MirrorMirrorOnTheWall
    I think it’s supposed to interact with MirrorMirrorOnTheWallSkill.
    It says you get to display text/videos/images on the magicmirror.
    What do you mean by "You need to return to the desktop and access them… outwith MM."
    Thanks.



  • This post is deleted!

  • Module Developer

    @johnnyboy looking at the modules read me linked above it uses youtube api to search for the video and an iframe to display the video from youtube on the mirror. And it uses google api to search for images to display.

    so no @arthurross you can disregard what johnnyboy is mentioning.

    But just looking at the read me it looks like a module with a certain degree of difficulty to pinpoint issues with unless you actually have access to the mirror it’s being used on (many points that could have been overlooked when installing).

    Do you get the module to display text? How do you know that alexa is responding? By audio confirmation?

    sudo shouldn’t be used unless actually defined in the instructions, that could create access issues for the main mirror software.



  • This post is deleted!

  • Module Developer

    @johnnyboy there is some issues with iframes due to cross domain restrictions. And I believe the biggest issue with iframes and youtube is that you can’t control playback (i.e pause/play, stop etc).

    I.e Loading a video with autoplay in an iframe does work, but to stop it you would have to close the iframe. (Somebody else with more knowledge on this should confirm or deny this)

    And the google requests in this module seems to use the api from google and not the actual webpage for searching, thus no fuzz with the cross domain restrictions



  • Hi Broberg,
    After a fresh install of the modules I managed to get Youtube working. Just no text nor images from Google.
    Do you know what’s wrong?


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.