MMM-awesome-alexa



  • @sdetweil so I followed the Audio guide, but immediately had to go to the Audio Troubleshooting section because no sound was coming out.

    Created the suggested audio settings file, rebooted, but the module keeps working like in my first post here…

    I am using HDMI output and a USB mic.
    They work perfectly with other modules or ie. with VLC playing.

    Edit
    My fault I didn’t run MM into dev mode so now I notice there’s actually an error when waking up the module, but I don’t know what it means.

    Does anybody have please a clue about what’s written below?

    MMM-awesome-alexa.js:1 Uncaught (in promise) DOMException: play() failed because the user didn't interact with the document first. https://goo.gl/xX8pDD
    


  • yep, not your fault… new browser restriction…

    fix in next version july

    workaround

    edit
    MagicMirror/js/electron.js
    add the line marked below

    let mainWindow;
    
    function createWindow() {
        app.commandLine.appendSwitch('autoplay-policy', 'no-user-gesture-required');  //< -------- added
    

    save, and restart Mm



  • @sdetweil cheers going to try it now! 👍🏽



  • @Canterrain said in MMM-awesome-alexa:

    Trying to finish setup of the module.

    I’m in the helper config, and when I get to the point of supplying a return URL I enter:
    https://localhost:3000/authresponse
    But terminal tells me that’s an invalid URL.

    I’ve put https://localhost:3000/authresponse as my return URL and https://localhost:3000/ as my authorized URL on the Amazon developer site. What I am I doing wrong here?

    Bump on this question, still can’t get past the local url section. Any help would be appreciated.



  • @Canterrain follow this guide.

    It worked for me.



  • @sdetweil finally I could hear the sound output of Alexa in my mirror!

    However for some reason it plays like if in slow motion. 😣



  • @Cr4z33
    Oddly that’s not working for me either. Maybe I’m doing something wrong?

    What should I be using for the Device ID? I’ve been using the product ID, but maybe that’s wrong.



  • @Canterrain no that is correct. 😉



  • @Cr4z33
    Well dang. I’m doing something wrong here. Whether I use the helper config or the tool above, I get a broken error page.

    And I know an error page is expected, but it’s not a long url with a code in it.
    It’s like… amazon.com/wpa

    and that’s it.

    Was the right choice “device with alexa built in” and “no companion app” ? I figure I must have done something wrong on the Amazon developer page, since that’s the part with no guide and it’s working for other people.



  • So does anyone actually have a step by step directions on how to set this up? Sorry i’m a huge noob, and I’m lost (which is probably due to the noob part). I do understand this is a difficult set up, but i’m kind of hoping there might be a detailed guide on this or even a youtube video (including how Amazon Developer should be set up).

    EDIT:

    I’m able to get to the auth request as most people, and I get the error: We’re sorry!
    An error occurred when we tried to process your request. Rest assured, we’re already working on the problem and expect to resolve it shortly.

    I understand this could either by my settings, or something on the amazon side, but has anyone gotten past this recently? Or is there another module I should be using?