MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

MMM-awesome-alexa



  • @vlatko_jordanov yeh, I went thru his videos, and I don’t see the actual alexa setup ON the mirror…

    I have sent him a message…



  • I can’t get the alexa module to do much… (on pi4)

    I have to say ‘Alexa’ then the black circle appears… but no voice reco
    I have to say ‘Alexa’ again, then the black circle goes to white, and SOME things are recognized.

    it looks like the module does not support conversational mode (add an event, sure, what date and time, xxx yyy, what do you want to call it, some test, ok adding some test at xxx on yyy)

    the main guts of the module haven’t been updated in 2 years… and they are minified, which makes debugging them almost impossible…



  • @sdetweil I think that could be down to having the old snowboy modules which can be updated following this guide here: https://www.howtogeek.com/423233/how-to-add-alexa-to-your-smart-mirror/

    It would suck if the videos the dude made were misleading and all that effort invested is in vain… well not entirely as there are other cool features to be implemented on the mirror but this was one of my main reasons, to have Alexa.

    Funny enough is that I have it linked it with AVS but as you said other modules are out of date and are probably not functional by now so yeah…

    Any suggestion to use other modules such as this but providing the full experience? Google assistant modules perhaps?

    EDIT:

    Alright this guy is busted… he never had any sort of module to control alexa over the mirror, here’s the parts he used which he never mention in his videos (ECHO DOT)

    http://gregensom.com/Build/SmartMirror/

    So yeah, hit me up with suggestions on this one, I either buy echo dot or I find a module and do it myself which I would prefer more 🙂

    EDIT2: Of which I am really confused by this bit in the video: https://youtu.be/aa3VVZA0e5Y?t=429 HOW?!!?

    Thanks,
    Vlatko



  • Hey guys,
    I run Awesome-Alexa on my RPi3. So far everything seems to work. The only problem is I cannot access my Smart Home devices. Same with Alexa Skills. Any idea why? Do I need an Echo device to make it work?



  • You are not the only one… i can’t control smartphone devices nor amazon music…



  • @Canterrain u need to do it quick. U have like 10 seconds to answer the questions. I had the same issue as well. Or maybe ur not typing the right device name.



  • @joel_afonso &
    I struggled like you to access my smart home devices. I’m German and my amazon account was bound to the German Amazon store. I knew that Alexa is working very limited outside the US. Some skills I wanted to use didn’t even exist the German skill store… very stupid thing. So I changed my Amazon Kindle Store region to the US-region, using this guide: https://intercom.help/wantboard/en/articles/1571875-transferring-your-amazon-kindle-store
    After that, I re-added the skills for Philips HUE and BluOS Voice Control and voila, it works. The only thing what still doesn’t work is using reminders and alarms.
    By the way: I already used Awesome-Alexa on my MagicMirror for quite some time (when it still run via the German Amazon store), so after I changed to the US store I had to re-configure Awesome-Alexa using this guide: https://www.howtogeek.com/423233/how-to-add-alexa-to-your-smart-mirror/
    Remark: in this guide they forget to mention to add “https://magic-mirror-avs.github.io/Alexa-Web-Helper/authresponse” to the allowed return urls in your AVS-product settings.
    To make sure I don’t carry over some old mistakes, I actually created a complete new AVS product on my developer account, so new client ID and secret, and so on.

    I can’t use Amazon music on my Magic Mirror, but I anyway play music via a NAD receiver in my living room. So its safe to say that Awesome-Alexa can control smart home devices (so it has access to skills), but almost no other capability which a real Amazon Echo would have.

    edit: I read a bit in the AVS console. what is funny: my MagicMirror can read Audible books. In chapter Entertainment you can see that Audible is approved:
    https://imgur.com/7uE7iEg
    In order to make Amazon Music (and other services) running on your Mirror, you technically have to submit your application for review to Amazon. So I guess its safe to say that you will probably never get this approved.

    Try it 🙂



  • @dolanmiu Hello, i know you probably get asked this alot, but i got the client id and client secret, but I can’t figure out what to put for the allowed return urls, or how to find/make them on the amazon dev side and on the magic mirror side



  • @sdetweil said in MMM-awesome-alexa:

    @vlatko_jordanov I am trying to set this up but my brain cannot figure out what I am supposed to put in as the return url in the AVS setup…

    edit: DOAH… read the instructions!!! lol… it is EPEXCTED to FAIL to connect… read the text from the failing url

    got that… BUT then next step fails for me…

     Enter your Authorization code (from previous step): ANMJShcLPpSKjJkKLbzj
      ◡ Getting response from Amazon...(node:2772) UnhandledPromiseRejectionWarning: StatusCodeError: 400 - {"error_description":"The request has an invalid grant parameter : code","error":"invalid_grant"}
    

    @sdetweil , man am I happy to see you in here…First things first, I searched within your github page for a way to make a donation to you fir your help and efforts but found nothing…Point me in the right direction to do so please! Once you do, I will gladly show some appreciation to you 😉

    Once that is done I hope you might help in the above situation. I get to this point in the Configuration Helper Tool and have no clue as to what I should enter for a Redirect uri and I never read anywhere about it supposed to fail. And then in advance I’ll ask about the next part you mention where you say the next step fails for you. Did you figure that out?

    Thank you!

    Note: I do have an echo dot device in my home and from reading numerous comments, this seems to help in some way…

    Also, when adding the recommended line to the elctron.js file is it supposed to simply look like this?

    });
    
    // Start the core application if server is run on localhost
    // This starts all node helpers and starts the webserver.
    if (["localhost", "127.0.0.1", "::1", "::ffff:127.0.0.1", undefined].indexOf(config.address) > -1) {
    	core.start(function(c) {
    		config = c;
    	});
    app.commandLine.appendSwitch("autoplay-policy", "no-user-gesture-required");
    }
    
    

    It does not appear so…As if it is too simple…



  • @bumrocks you don’t need that line anywhere, we added it back in 2.9 as part of the base.

    as for the alexa thing, the way the process works, you use the client id/and secret, and some uri to call back to when the authorization is comnplete…

    but there is nothing running on your pi to call, so it errors out,

    BUT the url it is trying to call is right there with the code you need to copy

    SO, knowing there is nothing to call back to, just use http://localhost:1234

    then the web page will come up, you give permission, and then it tries to call http://localhost:1234 with the access code, and fails, but the code is show on the address bar line

    ps… I don’t take contributions… I do this cause I like it.


Log in to reply