Mirror Not Visable



  • I’m extremely new to raspberry pi and I’m honestly not 100 percent sure what I’m doing, so I apologize in advance if you need much more information than I will provide in this initial post. I’m using a Raspberry Pi 3 and thought I had followed the instructions on github (https://github.com/MichMich/MagicMirror) exactly, but when I start my Pi it just brings me to its desktop. Theres no page that shows up for the mirror. when i use pm2 start mm.sh it says disabled under watching. Does that have anything to do with it? Let me know if theres any other information you need, thanks.


  • Module Developer

    @C13INTZ There is a very in-depth installation guide posted here. Give that a try and see if it helps.



  • When I tried using this guide i received a whole list of npm errors


  • Module Developer

    Can you provide the errors you are receiving from npm.



  • This happens to me to.
    Using rPi 2 with latest Jessie, trying to make an fresh install of MM2 after i went total berserk and changed to much in config files and tried 3 party modules.
    First try i followed instructions on Git, but it didnt help. Then i tried @KirAsh4 's Setup guide, got to npm start step, and was seeing an error message. Thought i was to hasty and missed something, so i did it again. I read and re-read all the steps before re-installing calmly and safe :) Then at npm start same thing happend.

    from npm-debug.log:

    0 info it worked if it ends with ok
    1 verbose cli [ '/usr/bin/nodejs', '/usr/bin/npm', 'start' ]
    2 info using npm@3.9.5
    3 info using node@v6.2.2
    4 verbose run-script [ 'prestart', 'start', 'poststart' ]
    5 info lifecycle magicmirror@2.0.0~prestart: magicmirror@2.0.0
    6 silly lifecycle magicmirror@2.0.0~prestart: no script for prestart, continuing
    7 info lifecycle magicmirror@2.0.0~start: magicmirror@2.0.0
    8 verbose lifecycle magicmirror@2.0.0~start: unsafe-perm in lifecycle true
    9 verbose lifecycle magicmirror@2.0.0~start: PATH: /usr/lib/node_modules/npm/bin/node-gyp-bin:/home/pi/MagicMirror/node_modules/.bin:/usr/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/local/games:/usr/games
    10 verbose lifecycle magicmirror@2.0.0~start: CWD: /home/pi/MagicMirror
    11 silly lifecycle magicmirror@2.0.0~start: Args: [ '-c', 'electron js/electron.js' ]
    12 silly lifecycle magicmirror@2.0.0~start: Returned: code: 1  signal: null
    13 info lifecycle magicmirror@2.0.0~start: Failed to exec start script
    14 verbose stack Error: magicmirror@2.0.0 start: `electron js/electron.js`
    14 verbose stack Exit status 1
    14 verbose stack     at EventEmitter. (/usr/lib/node_modules/npm/lib/utils/lifecycle.js:245:16)
    14 verbose stack     at emitTwo (events.js:106:13)
    14 verbose stack     at EventEmitter.emit (events.js:191:7)
    14 verbose stack     at ChildProcess. (/usr/lib/node_modules/npm/lib/utils/spawn.js:24:14)
    14 verbose stack     at emitTwo (events.js:106:13)
    14 verbose stack     at ChildProcess.emit (events.js:191:7)
    14 verbose stack     at maybeClose (internal/child_process.js:852:16)
    14 verbose stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:215:5)
    15 verbose pkgid magicmirror@2.0.0
    16 verbose cwd /home/pi/MagicMirror
    17 error Linux 4.4.14-v7+
    18 error argv "/usr/bin/nodejs" "/usr/bin/npm" "start"
    19 error node v6.2.2
    20 error npm  v3.9.5
    21 error code ELIFECYCLE
    22 error magicmirror@2.0.0 start: `electron js/electron.js`
    22 error Exit status 1
    23 error Failed at the magicmirror@2.0.0 start script 'electron js/electron.js'.
    23 error Make sure you have the latest version of node.js and npm installed.
    23 error If you do, this is most likely a problem with the magicmirror package,
    23 error not with npm itself.
    23 error Tell the author that this fails on your system:
    23 error     electron js/electron.js
    23 error You can get information on how to open an issue for this project with:
    23 error     npm bugs magicmirror
    23 error Or if that isn't available, you can get their info via:
    23 error     npm owner ls magicmirror
    23 error There is likely additional logging output above.
    24 verbose exit [ 1, true ]
    
    

    EDIT:
    Totally forgot that i was SSH:ing :/
    DISPLAY=:0 nohup npm start & Worked like a charm!

    Would be nice to edit the Setup guide with that ;)


  • Moderator

    The guide is written for the bare basics. Using SSH to log in to it and execute those commands isn’t covered because in order to actually set it up from the start, you would already have physical access to it. Remote SSH isn’t for everyone and is not required for the installation and configuration of the rpi nor MM².

    That said, it will be covered in an upcoming tutorial which covers things like installing pm2 to auto start npm, and remote access. Remote access is different for everyone, there is no fixed way of doing it. My network isn’t the same as yours, or others.


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.