MagicMirror not starting



  • Hi all,

    I have an issue with starting the MagicMirror. Checkin the log file I can find the following:

    0 info it worked if it ends with ok
    1 verbose cli [ ‘/usr/local/bin/node’, ‘/usr/local/bin/npm’, ‘start’ ]
    2 info using npm@5.0.0
    3 info using node@v8.0.0
    4 verbose run-script [ ‘prestart’, ‘start’, ‘poststart’ ]
    5 info lifecycle magicmirror@2.1.2~prestart: magicmirror@2.1.2
    6 silly lifecycle magicmirror@2.1.2~prestart: no script for prestart, continuing
    7 info lifecycle magicmirror@2.1.2~start: magicmirror@2.1.2
    8 verbose lifecycle magicmirror@2.1.2~start: unsafe-perm in lifecycle true
    9 verbose lifecycle magicmirror@2.1.2~start: PATH: /usr/local/lib/node_modules/npm/bin/node-gyp-bin:/root/MagicMirror/node_modules/.bin:/usr/local/sbin:/usr/local/b$
    10 verbose lifecycle magicmirror@2.1.2~start: CWD: /root/MagicMirror
    11 silly lifecycle magicmirror@2.1.2~start: Args: [ ‘-c’, ‘sh run-start.sh’ ]
    12 silly lifecycle magicmirror@2.1.2~start: Returned: code: 1 signal: null
    13 info lifecycle magicmirror@2.1.2~start: Failed to exec start script
    14 verbose stack Error: magicmirror@2.1.2 start: sh run-start.sh
    14 verbose stack Exit status 1
    14 verbose stack at EventEmitter. (/usr/local/lib/node_modules/npm/lib/utils/lifecycle.js:283:16)
    14 verbose stack at emitTwo (events.js:125:13)
    14 verbose stack at EventEmitter.emit (events.js:213:7)
    14 verbose stack at ChildProcess. (/usr/local/lib/node_modules/npm/lib/utils/spawn.js:40:14)
    14 verbose stack at emitTwo (events.js:125:13)
    14 verbose stack at ChildProcess.emit (events.js:213:7)
    14 verbose stack at maybeClose (internal/child_process.js:887:16)
    14 verbose stack at Process.ChildProcess._handle.onexit (internal/child_process.js:208:5)
    15 verbose pkgid magicmirror@2.1.2
    16 verbose cwd /root/MagicMirror
    17 verbose Linux 4.9.35-v7+
    18 verbose argv “/usr/local/bin/node” “/usr/local/bin/npm” "start"
    19 verbose node v8.0.0
    20 verbose npm v5.0.0
    21 error code ELIFECYCLE
    22 error errno 1
    23 error magicmirror@2.1.2 start: sh run-start.sh
    23 error Exit status 1
    24 error Failed at the magicmirror@2.1.2 start script.
    24 error This is probably not a problem with npm. There is likely additional logging output above.
    25 verbose exit [ 1, true ]

    Do you have any idea what I can do here for this topic?

    Thanks in advance



  • @Brian2312 A couple basic questions, if you don’t mind:

    • What version of Raspberry Pi are you using? (or other hardware)
    • Which installation path did you follow (such as the installation command from the GitHub page, or the complete startup tutorial, or other)?
    • Is this a new installation that has never worked or is this a previously working installation which has somehow stopped working?


  • Hi,

    I’m using the Pi3 with complete new installation. Raspbian Jessie is installed with additional ioBroker installation for some overviews of the hardware in the complete system.

    For the MagicMirror installation I’ve used the automatic installation line from the magic mirror page. So there was no manual installation from my side for the MagicMirror itself.
    I’ve updated the NPM and Node versions manually.

    Thanks in advance



  • It looks like you installed Magic Mirror as root. I would start by removing the Magic Mirror directory, switch user to the Pi user account, change to the home folder and then re-run the installation command. Hopefully that will solve it.



  • Hi,

    thanks for this. I will try this today evening and let you know if this was working.

    Thanks


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.