Listening to only 127.0.0.1:8080...


  • Module Developer

    Hi all,
    At last update, it seams the MM only listens to 127.0.0.1:8080 if I have set [] in the ipWhitelist.

    Here is the “start” of the mirror:

    [STREAMING] Now streaming realtime logs for [all] processes
    0|mm       | Starting MagicMirror: v2.1.3-dev
    0|mm       | Loading config ...
    0|mm       | Loading module helpers ...
    0|mm       | Initializing new module helper ...
    ...
    

    All is starting ok and the mirror shows up on the local screen.
    But it’s not available from any other IP.

    The start of my conf…

    var config = {
            port: 8080,
            ipWhitelist: [],
            language: "sv",
            timeFormat: 24,
            units: "metric",
    

    And the listing ports (IPs) with netstat:

    pi@MagicMirror:~ $ netstat --tcp --listening --programs --numeric
    (Not all processes could be identified, non-owned process info
     will not be shown, you would have to be root to see it all.)
    Active Internet connections (only servers)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0 127.0.0.1:8080          0.0.0.0:*               LISTEN      3486/electron.js
    ... (removed the other ports in the list) ...
    pi@MagicMirror:~ $
    

    As you can see it’s only listening on 127.0.0.1:8080…
    What have I missed/done?

    I can no longer access the /remote.html (for example) or any other “service” on the mirror from another machine.

    Best regards Snille


  • Module Developer

    It seems that you need to specify an IPv4 “address” in config, like this:

    var config = {
       ipWhitelist:  [],
       address: "0.0.0.0",
    }
    

    Worked for me…


  • Module Developer

    @Cato said in Listening to only 127.0.0.1:8080...:

    address: “0.0.0.0”,

    Ah! Thank you! :) Worked!


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.