MagicMirror² v2.14.0 is available! For more information about this release, check out this topic.

calendar *.ics file from local path

  • Hi,
    Is it possible to use in config.js file a calendar from e.g. /home/…/birthdays.ics or something alike?
    I tried various things, but nothing worked yet.

    Any sugestions?

  • Admin

    Officially it’s not supported. There might be a workaround, but I can’t help you with that.

    Of course you can always just put the local file behind a simple webserver to feed it using an URL.

  • How should that look like?

    I tried it with my webserver on qnap nas. I copied the ics files into the web root folder and tried to access them as following


    but that didn’t work either.
    I couldn’t find a solution to access my owncloud calendars directly, so I have to extract them to a ics file and try to host them as that.

  • Admin

    That should just work. Maybe there is an other issue with your calendar file or network.

  • Well, I can access them with firefox and it shows me to open or download them.
    But it won’t work with mm2.

  • @co8
    Yes, I got it working after a bit of experimenting. It wouldn’t read the ics file from other places like /MagicMirror which I assumed to be the root of the webserver.

    I created a new directory in /MagicMirror/modules, named birthdays, and placed by birthdays.ics file in there.

    Then in my config I added a 2nd calendar:

    					symbol: 'birthday-cake',
    					url: 'webcal://localhost:8080/modules/birthdays/birthdays.ics'

  • Thank you shockwave.

    This works like a charm.

  • How can I set the topic to solved?

  • Moderator

    I did it for you. For future reference, you will have to set the topic as a question first, then you can change it later to solved. On the bottom right of the posts, there are three dots in a vertical line. Click on that to change the topic to a question (which will mark it 'Unsolved'), then when you’re ready to change it, click on the three dots again and you’ll have an option to set it to 'Solved'.

Log in to reply