MagicMirror² v2.4.1 is available! For more information about this release, check out this topic.
Please read the release notes carefully since this update requires adjustments to your Raspberry Pi configuration!

Error installing MagicMirror



  • I got following warnings during installation

    npm WARN stylelint-config-standard@17.0.0 requires a peer of stylelint @^8.0.0 but none was installed
    npm WARN grunt-stylelint@0.9.0 requires a peer of stylelint @^8.0.0 but none was installed
    npm WARN stylelint-config-recommended@1.0.0 requires a peer of stylelint @^8.0.0 but none was installed

    Unmet peer dependency stylelint@^8.0.0
    UNMET peer dependency stylelint@7.13.0

    npm WARN prefer global coffee-script@1.10.0 should be installed with -g
    npm WARN prefer global jsonlint@1.6.2 should be installed with -g
    npm WARN prefer global colorguard@1.2.0 should be installed with -g



  • Hello,
    Did you download the version:
    RASPBIAN STRETCH WITH DESKTOP ?
    I advise you to see this too: https://forum.magicmirror.builders/topic/4596/help-to-install-magicmirror
    Good luck


  • Module Developer

    These are not errors but known warnings. What is your problem, doesn’t it work and what doesn’t work because this is probably not a blocking installation error.