Raspberry Pi Config Help - Unable to find - [SeatDefaults] To add the following line below xserver-command=X -s 0 -dpms



  • Hi so I’m slowly getting into configuring my Raspberry Pi.

    I’m running Raspbian Stretch with desktop
    Image with desktop based on Debian Stretch
    Version: September 2017
    Release date: 2017-09-07
    Kernel version: 4.9
    Release notes: Link

    I’m following the details on this page https://github.com/MichMich/MagicMirror/wiki/Configuring-the-Raspberry-Pi

    I’m at the section for the screensaver and I’m at the step below.

    Add the following line below [SeatDefaults]

    xserver-command=X -s 0 -dpms
    

    But I’ve typed everything in correctly but I’m unable to find the line [SeatDefaults]

    at the top of the open screen reads
    GNU nano 2.7.4 File: /etc/lightdm/lightdm.conf

    Any help would be greatly appreciated.


  • Module Developer

    @IDCreate I never got the screensaver to disable properly with the configs as you have tried. I instead installed XScreensaver and then used that to disable screensaver and energy savings screen blanking.



  • This post is deleted!


  • @j.e.f.f

    Thanks very much j.e.f.f that’s very helpful advice. I’m pleased I’m not the only one that has had this issue. I couldn’t even find the code line [SeatDefaults] on the page /etc/lightdm/lightdm.conf . I’ll try your suggestion, Mykle1 had also suggested this option to me but I just wanted to dig a little deeper and find out why [SeatDefaults] was not in the script for GNU nano 2.7.4 File: /etc/lightdm/lightdm.conf

    I’m sure there’s probably a obvious explanation for it.

    So how do I install on my Raspberry Pi 3 and is it suitable.I’m running Raspbian Stretch with desktop
    Image with desktop based on Debian Stretch
    Version: September 2017
    Release date: 2017-09-07
    Kernel version: 4.9
    Release notes: Link



  • check file by:

    sudo nano ~/.config/lxsession/LXDE-pi/autostart
    

    if it includes:

    @xscreensaver -no-splash
    

    then just comment it by adding #

    #@xscreensaver -no-splash
    

    if it doesn’t work install xscreensaver:

    sudo apt-get install xscreensaver
    

Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.