RPI and HDMI->VGA converters..



  • Hi guys. Im in need of your help.

    Since I’ve build my mirror I have used 3 different HDMI -> VGA converters. (I got a http://www.ebay.com/itm/LCD-Controller-Board-DIY-Kit-RTD2270L-Driver-LVDS-Inverter-Turn-LCD-to-Monitor-/110925504614 as a endpoint).

    The first converter had a external powersupply. It work… For a day. Then it started blinking/flashing and was unstable pitchure and I saw that my mirror did not enjoy it. Bad power voltage and so on.

    Next converter i used is bugged on the RGB scale and shows the green color ALL THE TIME. This means some problems.

    Now, now I have bought a legit HDMI>vga converter from “The Pi Hut” or something. Now I only get “NO SIGNAL” on my display. And even on my regular TV-display
    I know that the converter works (tried in my computer and PS4) But It’s just my RPI2 that it doesnt work on… I have googled far and beyond with no resualts. I have tried edit the “/boot/config” file but no help…

    To the question: Have anyone been in my position? Does anyone know why this happend? RPI power problems? is it the LCD Controllerboard togheter?



  • Update…

    Now I know it’s something to do with my RPI… I borrowed a friends RPI (with my screen, SD-card, converter, enverything) it works like a charm. And he got the same RPI model.

    Someone know what could fix the problem?



  • Best i can say is, have you done an update and upgrade recently to your Pi (assuming you are on Rasbian or NOOBS OS)?

    sudo apt-get update
    sudo apt-get upgrade
    

    and make sure all drivers and configurations are current?

    Might start with a new installation of the Pi OS and go from there.

    May also need to try to find the differences in the configurations between your Pi and your friends.



  • @kckndrgn Thanks for replying!

    I’ve done a update/upgrade but same resaults, and yes, I’ve reinstalled Jessie on my SD card. But before I reseted my SD-card I tried it in his RPI and it worked. So
    My card -> His RPI, WORKS
    His cars -> His RPI, WORKS
    My C -> my rpi, NO
    His C -> ^^^^, NO.

    So it’s something with my hardware to do but can’t figure out how and why… It’s not like there is a BIOS reset anywhere either. :(
    And the powersupply should be good when I’ve used the same stuff on his RPI when it works. It’s so weird. It’s just a video output.



  • Sounds like you have a bad Pi then.

    Don’t know if there is any support in the Pi/Linux world but maybe you can use a USB to VGA adapter? I’ve got one on my PC (running winblows) for a dual monitor setup.



  • There is also this little beauty
    https://www.pi-supply.com/product/gert-vga-666-hardware-vga-raspberry-pi/

    it uses the gpio pins instead of the hdmi output.



  • @Knox I’ve thought about that but just that I’ve tried 3 different converters makes me mad when it doesn’t work for some unknown reason. But maybe I just have to accept it and buy one. :)


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.