MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

Disabling screen blanking

  • Hello!
    I am having a bit of trouble disabling the screen saver and screen blanking.
    I have followed the instruction in the guide:

    I can not edit the autostart file or replace it.
    I have tried installing xscreensaver, but it doesn’t show up under preferences like what I have read.

    Any help would be great!

    Edit: When ever I try to use the terminal to edit a file, whether the autostart or the lightdm.comf , the command can not be added as the pi says that there is no file or directory there to edit.

  • Project Sponsor Module Developer


    It sounds like you’re having trouble in the terminal. Honestly, it would be easier for you to install xscreensaver. Yes, I see you have tried. It does require a reboot after installation and then you would navigate to it from your Pi desktop.

    In your terminal
    sudo apt-get install xscreensaver
    sudo reboot


  • when I try to install xscreensaver, it comes up say that it has been installed. I have tried rebooting after the first installation of xscreensaver and I never got the option under preferences to go to screensaver.

    Is there anyway to uninstall xscreensaver so I can try again?

  • Project Sponsor Module Developer


    apt-get purge packagename or apt-get remove --purge packagename

    will remove about everything regarding the package packagename, but not the dependencies installed with it on installation. Both commands are equivalent.

    Particularly useful when you want to ‘start all over’ with an application because you messed up the configuration. However, it does not remove configuration or data files residing in users home directories, usually in hidden folders there. There is no easy way to get those removed as well.

    apt-get autoremove

Log in to reply