Possible Issue: MMM-GoogleAssistant with recent Google Assistant SDK update



  • Tried installing the MMM-GoogleAssistant today and tried to make it with the work with new google assistant sdk update… I ran in to this following error code:

    File "assistant.py", line 133, in 
      main()
    File "assistant.py", line 130, in main
      init_googleAssistant()
    File "assistant.py", line 124, in init_googleAssistant
      with Assistant(credentials) as assistant:
    TypeError: __init__() missing 1 required positional argument: 'device_model_id'
    hello from python!!
    

    any ideas on what is causing the problem?



  • I’m having the same issue. I followed the instructions listed link text here and can get the sample assistant script to run from Google, but when I run the assistant.py script, I get the same error as above.



  • Solved it!

    The SDK update changed the assistant initiation call. You registered a device_model_id (“Raddys-magic-mirror-device-id” for example) in the original instructions, so you have to add that to the assistant.py file. (Here are instructions on manually registering a device and creating a device instance–I don’t know if an instance is required for this to work, but it’s part of what I did trying to solve this).

    Open the assistant.py code and scroll down to line 124. The current call is this:

    with Assistant(credentials) as assistant:
    

    In the updated method found on Google’s dev site, it should read:

    with Assistant(credentials, device_model_id) as assistant:
    

    Where you replace device_model_id with whatever you registered before.

    with Assistant(credentials, "Raddys-magic-mirror-device-id") as assistant:
    

    Run it and it should work!


  • Module Developer

    @Raddy said in Possible Issue: MMM-GoogleAssistant with recent Google Assistant SDK update:

    d method f

    just an update. I’ve updated the MMM-GoogleAssistant module to work with the new SDK 🙂