No Data in Module MMM-Formula1



  • Hi everybody!

    I installed the Formula 1 Module and copy the Code in the Config.js. When i start the MM, i get no Data present for the Formula 1 Module.

    What can i do, to get the Informations on the Screen?

    Regards,
    Daniel



  • @ostfilinchen I’m guessing you have Error: Cannot find module 'ical-generator' in your console, if so then do the following cd ~/MagicMirror/modules/MMM-Formula1 and then type npm install



  • Yeah. It works. Can u change it in the readme, that i must install these plugin.


  • Module Developer

    @ostfilinchen That’s standard for all modules.

    Once you have cloned them, you need to install them



  • @Mitchfarino said in No Data in Module MMM-Formula1:

    @ostfilinchen That’s standard for all modules.

    Once you have cloned them, you need to install them

    Actually that is not a gerneral rule. Not every module has NPM Dependencies. When there is a package.json file and there is an object called dependencies you have to type npm install, but there can be npm dependencies also without a package.json file, when the developer doesn’t create one he will tell something about this in the install instructions.

    In this specific readme there is a small hidden notice about installing dependencies in Displaying the Race Schedule section, but it is necessary anyways, so it should be moved to the install instructions @ianperrin


  • Module Developer

    @strawberry-3.141 ahh, my bad!

    apologies for the confusion



  • @strawberry-3.141 said in No Data in Module MMM-Formula1:

    @Mitchfarino said in No Data in Module MMM-Formula1:

    @ostfilinchen That’s standard for all modules.

    Once you have cloned them, you need to install them

    Actually that is not a gerneral rule. Not every module has NPM Dependencies. When there is a package.json file and there is an object called dependencies you have to type npm install, but there can be npm dependencies also without a package.json file, when the developer doesn’t create one he will tell something about this in the install instructions.

    In this specific readme there is a small hidden notice about installing dependencies in Displaying the Race Schedule section, but it is necessary anyways, so it should be moved to the install instructions @ianperrin

    This is what i mean with “Can u Change it in the readme, that i must install these plugin.”

    Install the ical-Generator is necessary to run the module.

    Thanks guys for helping :-)



  • So in adding the calendar functionality to the module, my goal was to make it (and the ical-generator dependency) optional so that those who didn’t wish to use it could simply clone the repo, add the basic config and be up and running. Whereas those who wanted the calendar, could go through the additional npm install steps.

    I tested this with the following set up:

    • On my Dev machine, I have the ical-generator package installed. Here I can set the calendar configuration option to true or false and the module works without error
    • On my Pi, the ical-generator package has never been installed. Setting the calendar option to false, allows the standings table to be displayed, but setting it to true triggers an error. Furthermore, omitting the calendar option from the config also triggered an error.

    On investigation the default value for the calendar option was set to true. Thus always forcing the ical-generator package to be required. I’ve updated the code to correctly set the default to false and now the Pi instances works as expected without the package if the option is not set in the config and if it set to false .

    Could it be that in your instance, the config for MMM-Forumla1 did not include the calendar option, therefore, the module failed?

    Perhaps someone could confirm this by running npm uninstall ical-generator in the module folder, then git pull to get the latest version of the module, then set calendar: false in the config options and see if the standings display?



  • @ianperrin: thanks for Change the Default Config in your module. I’ve updated my Installation an it works!


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.